Incorrect number of arguments for command 'test'

I tried to do an android build of my project (which was compiling to other targets fine.)
The compile failed, and after that the project won’t build at all, I just get an error:

Error: Incorrect number of arguments for command 'test’
build failed

I’ve updated everything (opnefl, lime, haxecpp etc.) and project still won’t build, other working projects also fail in the same way.

Any ideas how best to resolve?

Maybe You are passing architecture switches also?
What is Your command to invoke build process?

Ok… I don’t really understand what you mean - I’m using Atom, and just set the target and hit cmd-b
But, what you said made me think - and I tried building from the command line which also works fine - so I think this may be an issue with Atom.

Maybe instead of running build You could create atom script and run it instead? I mean create script which will invoke Your command properly.

Yeah, I could do that, but I’m pretty keen to understand what’s got broken… It was all working fine.

Probably Your atom-build file has errors.
Could You paste it here?

Yes! where can I find it?

Well, how did You set up Your Atom environment? Do You have build plugin installed?
I assume You are bulding with this package


Ahh, You are using dedicated lime/flow Atom package, not “build”.
What other info do You have when building beside the error?

In package -> lime/flow/haxe (dependent what plugin You are using) You have “toggle Log view”.
Could You paste text from that window here?

That is the error from the lime log view - there’s nothing else… (which makes it pretty hard to pin down what the problem is.)

I’ve actually posted this issue in the forum, as I can now build to all targets (inlcuding android) from the command line. It’s not an openFL/Lime/Haxe issue.

Hmm… Do You have autocompletion working? For example - can You start writing import and have suggestions of files possible to include?

Yes, the linting, autocomplete etc. all work fine.

Thanks for your suggestions, I appreciate it!

(I have also tried opening atom from the command line, which fixed similar issues previously)

1 Like

Best regards, Ret