I need help installing Openfl

Dear community, I downloaded haxe-3.2.1-win.exe , I installed it then opened a command-prompt (Windows)

and write this code: “haxelib install openfl” it worked , but later when I wanted to run this code : "haxelib run openfl setup " I faced a problem.

Called from ? line 1
Called from CommamdLineTools.hx line 1330
Called from CommamdLineTools.hx line 25
Called from CommamdLineTools.hx line 64
Called from CommamdLineTools.hx line 1037
Called from /usr/lib/haxe/std/neko/_std/sys/io/File.hx line 30
Uncaught exception - [file_contents,/haxelib.json ]

Please hep me.

Looks like there’s something wrong in the haxe install. But I’m not a Windows user so I’m really not sure, hopefully somebody else can chime in.

If you run haxelib list what does it show?

This is what I get.

Looks like you have some libraries up-to-date while others are out-of-date. That might be the problem.

Try haxelib upgrade, which will update all of your libraries. Then try haxelib run openfl setup again. I hope it works!

Tanx Dear, It worked :slight_smile:
Thank you so much.

Great! :slightly_smiling:

My Editor of choice aka FlashDevelop says:" it cannot find haxelib.exe in SDK path". What does it mean and how can I fix it ?

check this: https://groups.google.com/forum/#!topic/haxeflixel/a0HfARd_zbM

thanks for the reply Dear wuprui.
but one of the first things I checked was to make sure the the Haxe SDK path was actually referenced properly in Flash Develop.
It is indeed correctly pointing to my …
… directory, where haxelib.exe lives. That was the default directory that was created during the install.

http://puu.sh/jMQyV/cd2efbedb2.png is what I see when loading up a working program.

do you run FD as administrator?

One more attempt: if you have installed haxe manually try to uninstall and let FD install it himself. Tools/Install Software

I did what you suggested, It did not help

I noticed when I open FD and the open the project using project>open project , I don’t see this error
I still see it when I go to the project file and Rightclick on it and then choose open with FD.

it’s strange. Try set FD to ALWAYS run in administrator mode… Or open projects by project>open project ))