I can't test my projects anymore

Hi, everybody!

I’m grabbing assets from a SWF, but when I run…
openfl test html5


openfl test flash

… I receive this error in the VS code terminal:
C:\HaxeToolkit\haxe\std/haxe/macro/Type.hx:476: characters 21-27 : Too many type parameters for Map


Are you using the latest versions of Lime/OpenFL and Haxe?


I installed everything recently, but anyway I ran haxelib update and I still get the same error.

Another message that has come up is this. Does it have something to do?

Unable to build cache - completion features may be slower than expected. Try fixing the error(s) and restarting the language server.

Source: Haxe (Extension)

Show Error


Okay it’s good to eliminate the code version thing. You say “anymore” so I am curious what changed in your code, especially pertaining to what Map you are using. Can you show your code?

I wouldn’t worry about the cache thing. The VSCode extension is finicky. Doing Command/Control-Shift-P you can try restarting the Haxe language server but that doesn’t always fix things.


After reading your comment, I decided to grab the SimpleSWFLayout sample again and give it a try and it worked. So I just copied and pasted my SWF file to this newly created folder structure and it’s now working.

Thanks a lot for your help!

1 Like