Hxscout works but not displaying anything

Hi, I’ve just installed Hxscout & hxtelemetry lib and ran a test project using -Dtelemetry in the prebuild to try but it isn’t displaying anything. It doesn’t crash but I can only see the time going. In the test project I have 2 movieclips from a .swf file and add them to the the root’s displaylist. Openfl 8.2.2 Lime 6.4 Haxe 3.4.7.
My project.xml:

<?xml version="1.0" encoding="utf-8"?>
<!-- output -->
<app main="Main" file="TestOpenfl" path="bin" />

<window background="#000000" fps="60" />
<window width="800" height="480" unless="mobile" />
<window orientation="landscape" vsync="false" antialiasing="0" if="cpp" />

<!-- classpath, haxe libs -->
<source path="src" />
<haxelib name="openfl" />

<icon path="assets/openfl.svg" />
<library name="ForestCharacters" path="assets/ForestCharacters.swf" preload="true" />
In the image below's what Hxscout's display looks like. I did some search on the net but haven't found a similar case most of which are about crashes, any ideas what's wrong or missing?

i remember that adobe scout had issues connecting/getting telemetry to flash content in some browsers (chrome?). perhaps try multiple browsers, see if this might be the issue?

Is this a C++ application? Did this previously work?

@Karg I’m using Hxscout not adobe scout, @singmajesty I tried on neko, flash,air & c++ targets none gave any results and this is the first time I use it.

Hi, I think you just need to add the hxtelemetry lib to your project.xml :

<haxelib name="hxtelemetry" if="cpp" />

I also use this to enable it :

<!--telemetry for hxScout-->
<haxedef name="telemetry" if="cpp" />
<!-- for mobile and distant devices -->
<!--<config:hxtelemetry host="" allocations="true" />-->

It works for me this way, except it crashes when using Starling last time I tried :slight_smile:

1 Like

Actually, that shouldn’t be needed - OpenFL already includes the hxtelemetry haxelib if telemetry is defined:

In my experience, you really only need -Dtelemetry.

I tried again and it worked only for windows/c++ target, figured I forgot to add the -Dtelemetry for that one but for neko it just displays like in the screenshot and for the flash & html5 targets it doesn’t send any data/doesn’t connect to hxscout at all. So does the current version of hxscout only work of c++ target atm?

Oh nice, didn’t know that ! My bad

@EagleNebula there is a dedicated page for SWF profiling ( https://hxscout.com/swf.html ), aside from that it’s meant for c++ target if I understand correctly

Yeah I’ve already read the swf page so if I can get that to work guess I’ll be targeting flash whenever I need to track performance and yeah guess it’s meant for c++ thanks for clearing it to me ^^

I get “…/HxTelemetry.hx:3: characters 7-21 : You cannot access the sys package while targeting flash (for sys.net.Socket)” whenever I add a -D telemetry option.
And that’s the first import line in HxTelemetry.hx -> import sys.net.Socket;
Then it goes on to complay about Thread is a Type not found… but it’s obviously stuck at asking for illegal packages.
Anyone got this working for flash ?

For flash use haxe <haxedef name="advanced-telemetry" if="debug" /> instead, and remove the -D telemetry option.
Tell me if that works.

Does this help?

Let me know if we should do more here in the OpenFL include file for the Flash target

It doesn’t pick it up.
I see the:
“FLMListener.hx:24: Starting FLM listener…
FLMListener.hx:29: Waiting for FLM on 7934…”
but nothing else after that, happens.

Still not picking it up after that one.
Must go back to using sysinternals process explorer and a stick to inspect little kittens insides. Such is my fate.

Btw I tried it on Adobe Scout so try that instead but even then I tried it on a sample project so there were no use of sockets etc. Besides there’s a specific version of hxscout for the Flash target and I know that Flash doesn’t allow access to most of the system features like file system etc so maybe it doesn’t allow sockets as well, which might work fine on AIR if your not aiming for the web.