HTML5 target not working after update [SOLVED]

Hello gents.

I have just updated OpenFL via ‘haxelib update’, and now all my projects don’t work, at least not when targeting HTML5.
They do compile (I had to update Lime too for that), but when I try to run them all I get is a black window.
Also trace() does not produce any results (needless to say I am compiling in Debug mode) and my browser’s console stays empty.

I have tried different browsers to no avail.
Windows target still works as before.

Looking through older topics, I could not find anything similar to this, so I wouldn’t know where to start and any help is appreciated.


Does it get past the preloader? Do OpenFL samples work for you? Do you use filters or cacheAsBitmap?

1 Like

I was just going to check what you asked, when I realised I had a bad index.html template :blush:
I think I tried to customise it the wrong way in the past (when I didn’t know I could have a custom template folder in my project instead).
Everything’s fine now, thanks! :slight_smile:

1 Like