HTML5 target build warnings and nothings renders in browser


My current setup :

Nodejs    v10.15.3
OpenFL    8.9.1-LoCUP5
Lime      7.5.0

I am trying to compile a simple newly created project

i am using VS Code but using command line tool to test .

openfl test html5 -clean -v

as soon as i add assets path and add some files to the folders.

<assets path="Assets" rename="assets" />

i am getting:


and because of the warnings, i can’t see any render in the browser.

i tried FlashDevelop and it compiles without errors so for now i am compiling the project from FD and coding in VS code . i tried to find the cause by switching to older versions of lime and openfl but no luck, back in the days i used to compile my projects by using openfl tool .


I think the open gl in your browser might be off. Turn it on, it’s labelled as hardware acceleration.
And is found in browser’s settings.

hi, i double checked it and it’s enabled already

If you can extract out the code that is causing the problem, I can test at my side.


does it work compiling with -Dcanvas?

This let me compile from the command line.

openfl test html5 -clean -final -v -Dcanvas

But it is throwing some warnings along with 100 of lines of js gebrisch with some empty areas and some ^^^^ :mask:.

and in the end

@VishwasGagrani .

This is not specific to my code but i am getting it out of the box when i create a new project.

Here are the steps:

λ mkdir openfl-html-test
λ cd openfl-html-test
λ openfl create project
λ cd SampleProject
λ openfl test html5

now add some .png files or fonts in the Assets folder.
and you will get the warnings in the browser.


What if you remove -final?

I think there is a regression in minification support due to how we embed dependency JS libraries

Just tried it without the -final, it is compiling without any warning and loading everything but loosing some things:

But it is working with FlashDevelop and not the command line tools.

For example :

Dynamic TextFields looks like :

when compiled from command line tools



when compiled from Flash develop



SimpleButtons aren’t responding to events but showing the static text field comming from swf:

and showing nothing in console of the browser if i click.

Loosing blur filter in swf lib :

when compiled from command line tools


when compiled from Flash develop


i hope this will help you .


Bizarre! Are they using different versions of OpenFL? What if you drop the -Dcanvas define?

Just tried openfl test html5 -v -clean and it compiled without any warning but now the browser is not responding and i am sure these are the same WEBGL warnings in the console, printing infinitely.

i double checked the versions :


and in FlashDevelop:



i tried to add -Dfdb too but no luck.