[HTML5] New to OpenFL, can't get past preloader for samples


I have a project at my university where I’m supposed to create a prototype for a serious game, and since I’m completely new to game development I’m now trying to research some of the different game engines out there. Thought OpenFL could be a nice start since it seems rather lightweight.

I have followed the instructions, installed with Haxelib and tried to run some of the samples. Unsuccessfully. I did it in HTML5 (as that was the example from the instructions), but it always ends with me getting stuck on the preloader logo. Can’t find any error, neither in the console nor in cmd.

It might be a trivial problem, and I’m sorry for asking a dumb question if it is, but I’m in a bit of a hurry today and don’t have time to do the normal google-research.

Hi, and welcome :slight_smile:

Did you use openfl test html5, to allow our tools to open a browser and start a web server for you, or did you click the “index.html” file yourself?

What browser are you using?

Can you try using openfl test neko (which is a slow target, but works without extra dependencies), or another target? Do those work?

Have you tried “DisplayingABitmap” yet? Which sample isn’t loading?

Well, I feel a bit dumb right now.

I tested DisplayingABitmap and another one (which I don’t recall the name of right now as I deleted it for some reason), and since they both brought up the same image (the OpenFL logo) I just assumed it was an error. Tried a couple other samples right now, and it works like a charm.

So I guess it was all because of me being stressed, feeling like I didn’t have enough time to explore a bit further.

Looking forward to explore OpenFL!

Please feel free to ask more questions, join the Slack or the Discord chat, and keep letting us know how we can help :grinning: