[HTML5 - Lime 5.8.0 - OpenFl 6.3.0] Invalid module : tools/tools.n

I have updated Lime and Openfl and now I receive this error when I try to compile in FlashDevelop

Uncaught exception - load.c(398) : Invalid module : tools/tools.n

This was happening with the 2 previous versions too.
What’s the problem?

EDIT: do I have to update haxelib? :expressionless:

What version of Haxe are you using?

This occurs with a fresh, clean install of both Lime and OpenFL?

As in the title, Lime 5.8.0 + Openfl 6.3.0, the latest ones, but it happened with the previous ones too.

Well, if you mean fresh clean install made with “haxelib upgrade” the answer is YES.
But haxelib is an old version, because it is not capable to do selfupdate, as I wrote here.

What version of Haxe do you have?

“Haxe Library Manager 3.2.0-rc.3”

Try running haxe -version, is it Haxe 3.2.0, 3.2.1, or something older? Ideally it should be Haxe 3.2.1, Haxe 3.4.3 or Haxe 3.4.4

3.2.1 , it sounds like I should be safe.

Yes, this is strange. Usually, this error occurs if you have an old version of Neko, which is incompatible with a newer compiled Neko binary. Oh, perhaps you have an older version of Neko, which does not support larger Neko binary files. There is a file size limit for Neko scripts, which was updated in newer releases of Neko.

Does it work properly if you lime rebuild tools? Are you able to try a newer Haxe version?

It asked me to install “format”: I did it and launched your string but now I receive the same error as before.

I will reinstall FD and all, this will fix the problem for sure: both FD and Haxe are old, they need a refresh.

Okay, if you rebuilt and it still didn’t work, then I think it is the size of our tools.n file, not the Neko version. We might have to bump our required version to 3.4… we’ve been near the file size limit for tools.n for a while, we made some workarounds to reduce it, but the recent addition of the AIR target and some additional features might have pushed it over the edge again

Hey, as a quick workaround, could you try the following?

  1. Edit “lime/tools/tools.hxml”
  2. Add -D no-inline
  3. Run lime rebuild tools again

That might get us just under the threshold

No, it doesn’t work :expressionless:

I fixed it by upgrading Haxe to 3.4.4 (from 3.4.3) and neko to 2.1.0 (from 2.0.0)

1 Like