HL Building problems

Hello, I have a main problem with HashLink and is the library ssl.hdll,
It tries to load but makes an error every single time I try to compile.
Is there a Solution to this?

Try lime setup hl. You will have to download hashlink 1.10 binaries and setup the path. Then Lime will be able to copy ssl.hdll into your bin folder during compilation.

There are currently discussions to include hashlink into lime releases so this step would be unecessary. Please note that currently Lime copy only ssl.hldll. If you have other missing hdll, copy paste the missing hdll yourself from your hashlink binaries into your bin folder. (It’s more a temporary fix than something well designed, so I hope a better solution will be found).


Ok so…
I tried lime setup hl
But it says No additional configuration is required.
And still ssl.hdll doesn’t copy on the thing.
If it helps I have lime 7.7.0

I think this automatic feature exists only since 7.9.0. But you can still copy the ssl.hdll from the hashlink binaries to your bin folder by yourself.

So I tried with the library ssl, and it works! but it’s kinda laggy.
So I work now with -Dno_ssl after hl, But thanks loudo for the help!