[HELP] OpenFL + Lime segfault

This is a copy from my StackOverflow question that no-one could answer.

Recently, I have found (on Mac OS X Mavericks) OpenFL and LIME (with the command line tools) not working due to a ‘segmentation fault’.

Before I get into the details, here’s some background.

I originally got Haxe + Neko from the installer provided from OpenFL’s site.
I installed OpenFL from the instructions there.
Later, when using standard Haxe coding I needed Neko but it wasn’t installed apparently.
I installed Neko from Neko’s site.
And now, I get this error when typing lime or openfl or using any of their functions (e.g. building):

Called from lime/utils/ByteArray.hx line 109
Called from lime/system/System.hx line 286
Called from lime/system/System.hx line 405
Uncaught exception - Segmentation fault
Anyways, I don’t know if the background has anything to do with it. I looked on the Ubuntu forums but nothing there worked for me. Any help would be appreciated; I can’t find much in ‘similar questions’ or anywhere else for that matter.

Haxe Compiler 3.1.3 + OpenFL 3.0.0 beta. (According to haxelib upgrade descriptions.)

So, I set my Nekopath, tried Haxe 3.2, Haxe 3.1.3, OpenFL 3.0.2, OpenFL 3.0.1, Lime 2.3.2, older Lime, ETC. They all have segfaults (at different lines).

Any answers? Thank you so much in advance, I really don’t want to abandon OpenFL - it’s such a great library and Haxe is a great language.

1 Like

Since it is not working I think the best is start over

  1. Install XCode

  2. go to haxe.org and download the installer for mac and install it

  3. after just do from shell

haxelib install openfl
haxelib run openfl setup
haxelib run openfl setup mac

at this point you shold be able to run a test app

haxelib run openfl create BunnyMark
cd BunnyMark
haxelib run lime test neko

I have reinstalled.
XCode has already been installed.

haxelib install openfl
 Current version is now 3.0.2

haxelib run openfl setup
  Current version is now 2.3.2
Called from lime/utils/ByteArray.hx line 110
Called from lime/system/System.hx line 304
Called from lime/system/System.hx line 419
Uncaught exception - Segmentation fault

Yep, it again fails at run openfl setup. Running anything to do with lime fails too.
I think it’s a lime error.

It’s weird. OpenFL used to work. It stopped working after I updated OpenFL, but when I downgrade it I get similar (but different) errors and end up with a segmentation fault.

all right.

yes it is definitely something about neko

honestly if you already reinstalled everything I don’t know how to help you more.

Actually, you may be right. It happened after I installed neko from the official neko website. I did this as the neko command wasn’t working with the haxe provided neko. Afterwards, when OpenFL didn’t work, I installed Haxe’s neko, but then it started to create segfaults. I’ll see whether there are still traces left or something.