Haxedevelop 5.3 -verbose / auto completion problem

Started using HaxeDevelop 5.3 and getting this:

“Error: Could not process argument /\\\_____________________________________________
invalid character: /”

when auto completion used to kick in, anyone getting this while using new 5.3 version ?
I think it’s the first lime ascii line. It happens with -verbose, if I cut it from the compile flags all is well and auto completion kicks in as expected… but no verbose.
Is there a way to counter this?

So you want to hard-code verbose mode into your build, but not have it in your target flags, because it sends this to your auto completion call?

Two options, I suppose. Perhaps we could disable -verbose with openfl display, or we could find a way to hard-code verbose so that it works always on a build, even without the flag. What do you think?

"Hard-code bad ?!!?"
I got to be honest, those are english words I recognize but couldn’t tell which is best.

Thanks :slight_smile:

I’ll make it so -verbose is ignored on lime display, unless -force-verbose is used. This should probably fix code completion, and is probably a good idea anyway :slight_smile: