Haxe openfl lime setup

Hello,

I tried to setup an Haxe environment on windows 10

first installed the latest 64bit haxe version haxe-3.4.7-win64.exe
then I did

haxelib install openfl
haxelib run openfl setup

no feedback from the setup command

openfl

although no feedback.

after installing lime with haxelib install lime

I tried to haxelib dev lime lime
got a directory not found.

hey, where is my fault. I am inside C:\HaxeToolkit\haxe
I see openfl lime format inside the lib folder

?

regards

PS: I did now haxelib dev openfl lib\openfl
getting Error: Error parsing haxelib.json for [email protected]: [file_contents,C:\HaxeToolkit\haxe\lib\openfl/haxelib.json]

You need to do
openfl setup windows
openfl setup android
etc.
and follow instruction.

hmmm, I followed this instruction
https://www.openfl.org/download/
and it failed on the second step!I can’t call openfl in any way. no error in the commandline!

the npm part on the left side works great, I ported a little starling project in no time to html5!

Make sure that haxelib and haxelib path openfl work, then try haxelib run openfl setup

haxelib path openfl give me:
–macro openfl._internal.macros.ExtraParams.include()
C:\HaxeToolkit\haxe\lib\openfl/8,6,4/src/

haxelib run openfl setup does nothing, --debug throws nothing…

that’s the openfl folder

Is Lime installed? Does Neko work?

lime is installed with haxelib install lime. is this ok?
how can I check neko?

Test haxelib run lime or just neko from a command prompt

neko: NekoVM 2.1.0 ©2005-2016 Haxe Foundation
Usage : neko

haxelib run lime: takes 1 seconds to return to the command line

haxelib list: lime: [7.1.1]

in my systemvariables
HAXEPATH ends with an \ “C:\HaxeToolkit\haxe”
NEKO_INSTPATH “C:\HaxeToolkit\neko”

which script is triggered with the setup command, perhaps I can put some prints in it to see where it stops.

Strange, I can’t think why Lime would not output anything. haxelib run lime -verbose also returns nothing?

nothing! is there something to setup lime propper

I will uninstall this version an make a reboot.

clean install, the same: no error, nothing.

which script inside openfl is called by ‘haxelib run openfl setup’? IS there a way to debug it?

ok, I didn’t understand the option 1 and option 2 installation difference. can I have booth installations, npm and the other. I seen I have the haxe verion 6.1 installed via npm.

can I have both version parallel, npm and haxelib?

I got with echo %errorlevel% this error number -1073741819. something wrong with windows UAC after the last update.

I switched to another user acount and everything works fine.

Oh, weird. Hmm.

To answer the other question, yes, you can have OpenFL installed from both Haxelib and NPM, the openfljs command is what is used by the NPM library, so as to not conflict with the Haxelib openfl command if it is also available :slight_smile:

thanks, I was a little paranoid with this installation issue. actually it’s an windows UAC error, nobody knows how to fix it.

Could it be anti-virus software?

I tried a lot of things, sfc scan, virus of, firewall of…