FlashDevelop: Neko_error bootable executable file was not found : neko.exe


#1

I just reinstalled Haxe, OpenFl and Flashdevelop the other day and trying to build to Neko using the FlashDevelop “Haxe OpenFL” template. All of the targets (windows, html, flash,…) work when running with F5 except for the Neko target

The Error I am getting is as follows

Running Pre-Build Command Line...
cmd: "C:\HaxeToolkit\haxe/haxelib" run lime build "project.xml" neko -debug -Dfdb
Called from tools/Tools.nml line 46
Called from core/Args.nml line 50
Called from core/Args.nml line 62
Called from tools/nekoboot.neko line 100
Called from tools/nekoboot.neko line 77
Exception : Neko_error(The bootable executable file was not found : neko.exe)
Build halted with errors.
Done(1)

I have the following latest installs

  • Haxe Compiler 3.4.7
  • OpenFl 8.5.1
  • Lime 7.1.0
  • FlashDevelop 5.3.3.1

The Neko binary is located at the default installation folder

Testing with Neko has always been fine in the past (~8 months ago) but after I installed the latest FlashDevelop and Haxe versions I am facing this error message.

Anyone having a clue?


#2

Does neko work from the command-line? Can you please test haxelib, haxelib run openfl -nocffi and haxelib run lime -nocffi, and see if any of them work? Thanks :slight_smile:


#3

I managed to solve it today myself, turns out the the Haxe uninstaller did not remove all previous system environment variables. The one that was left was Neko, I used to install it to my D:\ drive hence why I was able to notice this.

As a result when I re-installed haxe to C:\HaxeToolkit it did not create all environment variables correct, all haxe related ones were missing.

The expected environment variables I found via google at:

This solved the Neko building for me. So my problem has been solved.