FlashDevelop autocomplete issues with OpenFl/Haxe


I’ve been studying Haxe + OpenFL using FlashDevelop for the last few months, but I’m a total noob. Sorry if I’m asking this in the wrong place or asking this again.

Recently, whenever I create a variable or extend a class, I haven’t been getting the right options in auto complete.

It just goes like this screenshot here.

No sign of openfl.display.Sprite or flash.display.Sprite.

It always showed relevant options and worked just fine, but recently it’s not working well. Tried uninstalling/installing everything, but didn’t solve it.

Typing the imports by hand in the header helps solve this problem, but since I don’t know/remember all the packages, auto complete when directly typing the package name helps a lot.

Anybody had this problem?

Thanks. :slight_smile:

I had similar problem after updating flashdevelop to version 4.7.0 so I went back to 4.6.3.

Not sure which version of FD I’m running, but I have the exact same problem. As you say, as soon as the import is there, the problem goes away.

I’m running (I think) the latest version, which is

Will revert to an older version for now to see if it solves this issue.

Thanks for the replies :smile:

Try to use or change to another globally configured SDK in the project settings menu.

Hmm…changing the SDK didn’t work…but thanks for the tip :slight_smile:

Reverting to 4.6 worked for me though :sweat_smile:

Umm, I am using 4.7 and it worked well… try running it as admin? Maybe you have tried that already but just in case. Also you can try updating AIR and AS3 compiler in Tools -> Install Software.

Already tried these options before writing here. :sweat_smile:

None worked, besides reverting to 4.6

Same problem here.

Have you asked on the FD Forum as well for the issue ?

Yeah, I went there also, got asked if I received any report on the Output panel, but there was nothing to report. :confused:

Do you mind to post the link from the FD Forum here.
Don’t know why I can’t find it with the search function there… :confused:

Perhaps we should rise a issue on the flashdevelop github…

No prob, the link is this one: http://www.flashdevelop.org/community/viewtopic.php?f=13&t=12159&p=53301

One of the admins (Philippe) is answering there.

I’m preparing a better description of this issue to post on github. :slight_smile: Have been installing/uninstalling some versions of FD to test things.