Flash crashes immediately with Error #1001

I created a brand new example project with openfl create DisplayingABitmap.
Some targets work (openfl test html5 and openfl test android), but the flash build crashes immediately when loaded in the Adobe Flash Player Debugger with the following error:

Warning: Failed to parse corrupt data.
VerifyError: Error #1001: The method MethodInfo-65() is not implemented.

	at lime.app::_Event_Void_Void/dispatch()
	at lime.app::Application/createWindow()
	at openfl.display::Application/create()
	at ApplicationMain$/create()
	at ApplicationMain$/main()
	at boot_7d8a/init()
	at flash::Boot/start()
	at boot_7d8a()

I’m running Mac OSX 10.12.5, OpenFL 6.1.1-LFL3lN, and Flash Player Debugger

*Edit: Same error with OSX 10.12.6

Does this occur if you try openfl test flash -web?

Please try openfl test flash -debug also, as it may give us further information. This does not occur on my local version of Flash Player, but I am running version 25, perhaps 27 is a little different. We’ll try and look into this

Tested on Flash Player on Linux, working alright, but I’m aware the Linux version might behave a bit differently. I’ll try another system too

Just tried on Windows using Flash Player Content Debugger, and no errors either.

What version of Haxe and Lime are you running? Thanks!

openfl test flash -web opens the web browser to a blank white page. I assume the flash plugin is also crashing, but there are no visible error messages.

openfl test flash -debug displays the same error message that I posted earlier, with a tiny bit more info:

Warning: Failed to parse corrupt data.
VerifyError: Error #1001: The method MethodInfo-65() is not implemented.

	at lime.app::_Event_Void_Void/dispatch()[/usr/local/lib/haxe/lib/lime/5,5,0/lime/_macros/EventMacro.hx:101]
	at lime.app::Application/createWindow()
	at openfl.display::Application/create()
	at ApplicationMain$/create()[Export/flash/haxe/ApplicationMain.hx:88]
	at ApplicationMain$/main()[Export/flash/haxe/ApplicationMain.hx:79]
	at boot_7d8a/init()[?:1]
	at flash::Boot/start()[/usr/local/lib/haxe/std/flash/Boot.hx:70]
	at boot_7d8a()[/usr/local/lib/haxe/std/flash/Boot.hx:38]

I am running Haxe Compiler 3.4.2, and Lime Command-Line Tools 5.5.0.

Could you try installing Haxe 3.4.3? I haven’t seen this error before, and I can’t reproduce it here, but perhaps something funny is happening when processing the Haxe macro for Lime Event, perhaps something that’s fixed in Haxe 3.4.3? Thank you :slight_smile:

Updated the Haxe brew formula to 3.4.3, updated, reinstalled openfl. Same issue.

Does it seem like it is occurring here?

Can you try/catch it? Strange, again, that it is not showing up elsewhere :sweat:

Caught that error (though trace doesn’t appear to work in those files…), and now see the same error message originating from a different file:

Warning: Failed to parse corrupt data.
VerifyError: Error #1001: The method MethodInfo-624() is not implemented.

	at lime.app::Preloader/load()
	at ApplicationMain$/create()[Export/flash/haxe/ApplicationMain.hx:109]
	at ApplicationMain$/main()[Export/flash/haxe/ApplicationMain.hx:79]
	at boot_f72b/init()[?:1]
	at flash::Boot/start()[/usr/local/lib/haxe/std/flash/Boot.hx:70]
	at boot_f72b()[/usr/local/lib/haxe/std/flash/Boot.hx:38]

Running macOS 10.12.6, Haxe 3.4.3, Lime 5.5.0, OpenFL 6.1.2 and Flash Player Debugger, I am still unable to reproduce this problem.

It does look similar to this problem:


…but I don’t understand why this would be occurring now, on a newer version of Haxe, or why I can’t reproduce it.

I tested “DisplayingABitmap” and “PiratePig”