Error: zlib_deflate after upgrading to macOS High Sierra

I compiled my openFL project last night (succesfully) before installing the macOS update, now all i get is Error: zlib_deflate. I’m using IntelliJ Idea. which has been fine up to this point. can anyone shed some light on what the zlib_deflate error refers to?

Literally nothing else on my entire computer was changed except the os update

Information: - Running command: haxe -main ApplicationMain --macro openfl._internal.utils.ExtraParams.include() -cp /usr/local/lib/haxelib_3_3_0/openfl/4,9,1 -D openfl=4.9.1 --macro lime.Lib.extraParams() -cp /usr/local/lib/haxelib_3_3_0/lime/4,0,2 -D lime=4.0.2 -cp /usr/local/lib/haxelib_3_3_0/swf/2,3,1 -D swf=2.3.1 -D signal_stoppable -cp “# -D signal-strict” -cp /usr/local/lib/haxelib_3_3_0/signal/1,0,2/src -D signal=1.0.2 -cp /usr/local/lib/haxelib_3_3_0/actuate/1,8,7 -D actuate=1.8.7 -cp /Users/booboo/Documents/projects/haxe/RapellaFella/export/flash/debug/haxe/_generated -cp source -cp …/lib/HxAssert/src -cp …/lib/openfl -cp /usr/local/lib/haxelib_3_3_0/openfl/4,9,1/externs/core/flash -cp /usr/local/lib/haxelib_3_3_0/openfl/4,9,1/externs/core/openfl -D native-trace -D no-inline -D tools=4.0.2 -D swf=1 -D swf-parent-fps -D flash-use-stage -D no-compilation -D openfl-flash -D debug -D fdb -D verbose=1 -D web -swf-lib export/flash/debug/obj/assets.swf -swf-version 11.5 -swf export/flash/debug/bin/RapellaFella.swf -cp export/flash/debug/haxe -debug
Information:No additional error information available.
Error: (Command exited with an error code) 1

Well that’s a useless error message. No clue where it’s coming from.

I think you’ll have to narrow it down by trial and error. Does this happen with OpenFL’s sample projects?

Does this occur if you run openfl or openfl test flash -v from the command-line?

sorry for not responding, holidays are nuts.
I tried creating a test project just to see what happens

my versions:
actuate: [1.8.7]
box2d: [1.2.3]
hxcpp: [3.4.188]
layout: [1.2.1]
lime-samples: [4.0.1]
lime: [4.0.0] 5.9.1
openfl-samples: [4.9.0] 6.0.0
openfl: [4.9.0]
signal: [1.0.2]
swf: [2.3.1]

these were the versions this project used when it started, and I’ve put off updating them.

commands I ran:
cd [my project folder]
openfl create DisplayingABitmap
cd DisplayingABitmap/
openfl test flash -v

Does it work if you try a newer version of Lime and OpenFL?

nope, still getting zlib_deflate. tried deleting the project and creating a new one after haxelib upgrade. also tried resetting haxelib and all my libs entirely

Can you try a newer version of Haxe, perhaps Haxe 3.4.4? It sounds like this might be a Haxe error (like this thread:

this is odd, Ive tried remove and re-installing the latest haxelib, but it always says version 3.3.0. In fact, I’m pretty sure I already had 3.4.4 installed on this laptop, since I bought it about 2 months ago and would have probably installed the latest.

anywho, I decided to continue as though the displayed version was incorrect, and create a new DisplayingABitmap project. To my surprise, it worked!

I’ll keep moving forward and try out my old project tomorrow morning, but I really appreciate the help thus far

yup everything is back to normal, no idea why this started happening as soon as I updated my OS, though. Thanks!

Try haxe -version, perhaps both versions of Haxe were using the same haxelib version? (which doesn’t necessarily match)

Maybe you had Haxe 3.4.0-RC (or something similar) and now have the patched version of Haxe 3.4.4, I didn’t find 3.4.0 or 3.4.2 to be stable for OpenFL, or 3.4.3 stable for certain WIndows systems, so 3.4.4 is the first we’ve fully recommended from this release series