Error when launching game in Windows

Hello! My customers receive this error when trying to run my HaxeFlixel game:
could not load module [email protected]_application_create_prime

A few notes:

  • This seems to happen on any Windows PC that does not have haxe set up.
  • I was also able to replicate this error on a friend’s PC, so I can personally confirm that all .dll’s and lime-legacy.ndll were unzipped and present before running.
  • I’ve tried different versions of lime and hxcpp, as well as disabling many different features of the game that aren’t vanilla haxeflixel things.
  • Flash builds work fine.

I can’t find any other references to this error, and I’ve asked around several other places, I’m starting to get desperate! Help!

For reference, this is my project:

thanks :slight_smile:

Hi! which version of flixel You used? On recent 3.3.11 i’ve got missing flixel.effects.postprocess.PostProcess.hx and cannot rebuild.
Edit:
Maybe your custom preloader should be used just for web targets, and for desktops should be used flixel.system.FlxPreloader instead?

1 Like

Hey! I’m using the dev branch of HaxeFlixel, as far as the preloader goes, I’ve tried compiling with this in my Project.xml:
<app preloader="util.Preloader" if="flash" />

I’ve also tried removing the custom preloader altogether, as well as disabling the shader the game uses, disabling and removing the Newgrounds API, and loading a blank state instead of the PlayState.

Maybe shipping with neko.dll could solve problem?
Edit: Btw - did You compiled with -Dlegacy option? From the other hand, try adding also lime.ndll to app directory.
If that won’t work try renaming lime-legacy.ndll into lime.ndll

Is it a Windows build, or a Neko build? If you are using Neko, try Windows C++. To eliminate issues, potentially try building the Pirate Pig sample in C++, and see if the same issue occurs?

It is a windows build - and I’ve been able to compile a blank HaxeFlixel project and the error doesn’t appear - so I’m thinking it’s in my project, but without really knowing what the error means I’m having trouble trying to fix things. I’ve gone through the project several times, and nothing is really standing out.

So it runs on your machine? Can you trying sharing it with other people, and see if they have the same problem? Would I have the same problem?

There’s also the possibility, something is trying to pull from legacy and from the newer Lime code. HaxeFlixel forces -Dlegacy unless you add a “-Dnext” define. “lime_application_create” won’t exist unless you are building toward current OpenFL and not legacy

So far it seems like if you have haxe and lime setup, the game will run. You’re welcome to give it a shot!

Should I try to build with -Dnext?

Adding lime.ndll version 2.5.3 solves problem on my machine with binary You provided

I went ahead and installed lime 2.5.3 and rebuilt the ndll - on both my pc and my customer’s pc we get the error:
Null Function Pointer

Maybe as temporary fix add just 2.5.3 lime.ndll to previous build (to this archive You send with dropbox)? If it will work, You could redistribute that way untill this will be solved.

Sorry forgot to mention that I did that, and that is what is resulting in the error.

Any chance you could provide the zip so I can make sure my ndll is the same?

edited post were here.

Ah I’m dumb, I added lime.ndll but removed lime-legacy.ndll - it got rid of the error on my PC, hope to hear back from my customer soon.

Should be good - I got portable install, and it worked.
Best regards, Ret

My customer is still getting the error:
could not load module [email protected]_application_create_prime

I’ll have another pc available to me tomorrow so hopefully I can debug this more quickly.
Thanks for the help though!

Hmm… Last working lime.ndll for Your game on my machine is 2.6.1. Maybe try to add this version (or maybe this person added the file wrongly? Did You send to him full zip working archive, or just ndll itself?).

And does this person have WinXP?

I sent them the zip, and they tried running it zipped and extracted to a new folder. I’m pretty sure they’re running Win10 right now, was Win7 earlier in the week.

I’ll try uninstalling everything and installing that version of Lime.

Could it be an anti-virus system that is preventing it from loading the Lime NDLL somehow?