Error: float_for_string - ios simulator target

#1

When I run openfl test ios -simulator -v -clean, I’m getting:-

make
Haxe simulator build: Release-iphonesim-64
haxe Build.hxml -D simulator -D HXCPP_M64 -cpp build/Release-iphonesim-64
Error: float_of_string
make: *** [build-haxe-x86_64] Error 1
Command ExternalBuildToolExecution failed with a nonzero exit code

I had found a similar discussion when targeting windows which pointed to as3hx.Compat.parseInt as being the issue, but I’ve gone through my code fixing those, but I’m still getting the error.

Note: neko keeps quitting duration the command, I’m unsure if that’s related.

0 Likes

#2

Are you using embed="true"? I think this error can occur when Neko or the Haxe compiler runs out of memory

0 Likes

#3

What is the context of embed="true"? I only have @:meta(Embed(...)) in my code.

0 Likes

#4

Oh, it would be like: <assets path="Assets" embed="true" />

This bundles your files into the executable, but I’ve seen this cause issues with the compiler. float_of_string can mean that the compiler is out of allowed memory.

You could also try a 64-bit copy of the compiler instead of 32-bit, and see if that helps?

0 Likes

#5

My project.xml file only contains <assets path="Assets" rename="assets" />. I’m running Mac OS X 10.13.6 and there is only one version of haxe to download unless there is a compiler option to switch between 32-bit and 64-bit.

Any other suggestions?

0 Likes

#6

As I see real reason in as3hx was in FLOAT_MAX, you could try below fix

0 Likes