Error building HTML5 with swf assets: Uncaught [lime.utils.Assets] ERROR: There is no IMAGE asset with an ID

I have a project that I’m using swfs for image assets. I’m getting Uncaught [lime.utils.Assets] ERROR: There is no IMAGE asset with an ID of “AssetName:LibraryAsset”. The asset is imported using Assets.getBitmapData(“AssetName:LibraryAsset.”)

I’m able to load the asset in Flash just fine, but it fails in html5 and when I comment it out, the next asset from that swf does the same thing. I created a swf with simple graphics to test with, but that one is importing properly.

Has anyone had anything like this before? Is there a setting in the fla that could cause this? I don’t have the source flas for everything so I’m hoping that isn’t the case, but I do have the one that I am currently stuck on.

Fixed in dev, not released yet :slight_smile:

Sorry for the regression!

Sorry, should have added I’m running off git/dev. I’m using the same code method on a different swf and the other swf’s working fine, and openfl 4.4.1/ lime 3.4.1can work with my problem swf the asset in HTML5. All versions of openfl/lime can work with my problem swf in flash.

Would you mind sharing your simple sample with me, so I can reproduce the problem?

Thank you :slight_smile:

I’ll give it a shot in the morning. My trouble is that the asset that I created without my company’s assets seems to work fine. I run the same code found here: and then follow it with newing my company’s system. So I have two bitmapdata’s being loaded immediately and put on stage without issue, but later when my system starts a game it fails to load bitmapdata that is being loaded in what i believe to be an identical fashion.

I will try to get something a bit better tomorrow. I’m going to try a few things with my example asset i created to see if i can make it break the same way, but I’m unsure what I’ll find.

Here’s hoping!

I now understand what has been happening! The asset did not in fact exist in the fla! In lime 3.4.1, it would return null and because evidently i was never actually using the asset in question, this worked out fine. lime now has a breaking error (which I’m fine with now that I understand what happened) which prevented it from going any further. I removed the reference to the missing asset and it now runs! More over, Props on the major difference I’m seeing in my project going from 4.4.1 to 4.9.1+ So much of what was looking poor before due to unsupported html5 font features and such now look right, with outlines and everything! Assets that are set to lossless appear to be coming up transparent, so if that remains true, I may be able to get my project demoable!

Thanks for the help!

1 Like