Error #1063 on Away3D animator

Hi there!
I tried to create a spritesheet animation but stuck on an error. Double checked everything for hours, but cant find the problem. Here is the code. Compilling and running in flash, throws a mismatch error. Am i not seeing something? Thanks in advance.

Error #1063: Argument count mismatch on away3d.animators.states::SpriteSheetAnimationState(). Expected 0, got 2.

  var anim:String = "Anim";
  mat = new TextureMaterial(Cast.bitmapTexture("textures/ss_basic.jpg"));
  var spriteSheetHelper:SpriteSheetHelper = new SpriteSheetHelper();
  var animationSet:SpriteSheetAnimationSet = new SpriteSheetAnimationSet();
  var clipNode:SpriteSheetClipNode = new SpriteSheetClipNode();
  clipNode = spriteSheetHelper.generateSpriteSheetClipNode(anim, 2, 2);
  var animator:SpriteSheetAnimator = new SpriteSheetAnimator(animationSet);
  mesh = new Mesh(new PlaneGeometry(700, 700, 1, 1, false, false), mat);
  mesh.animator = animator;
  animator.fps = 4;;

Hmm. I tried the above code and everything seemed to work fine on Flash, Neko & HTML5 on my Mac. I was using the latest Away3D (5.0.4), OpenFL (6.2.0) & Lime (5.6.0).

The code was pretty much as is apart from the View3D setup.

It’s weird you are getting the argument error - expected 0 but got 2 as the signature for the SpriteSheetAnimationState constructor does indeed take 2 arguments :
… unless the error is for something else other than the constructor???

Not sure what else to suggest other than making sure you are on the latest code.

Let me go check something… Yep, they used Type.createInstance() again.

Either disable DCE, or use my fixed version.

Thanks Greg209 and player_03. I just figured it out that DCE might be the cause. By the way, vertex animators have the same issue, so it might be worth fixing it up as well.