Embed="false" not working anymore?


we are developing of a 'hidden object" game for html5.

Since I upgraded
openfl 4.4.4 -> 4.5.2
lime 3.4.1 -> 3.5.2

it seems all assets are preloaded at startup.
For example I have a folder with all music included like this:

<assets path="assets/music" rename="music" type="audio" embed="false"/>

or a folder with lots of images and other stuff:

<assets path="assets/nonembeds" rename="nonembeds" embed="false">

Both folders should be copied and content loaded at runtime, which worked fine till the upgrade of the libraries.



seems to have no effect.

I couldn’t find any new information how to add Assets and prevent them from preloading, so help is very much appreciated :slight_smile:

Tanks a lot!


I think this is a regression on HTML5, I’ve created an issue and will try and look at it very soon :slight_smile:

Hmm, this does still seem to work. I wrote about it in the issue here:

Hi, at fist: Thanks for your effort!

but there must be something different / wrong.

lime 3.4.1, openfl 4.4.1

lime 3.5.2, openfl 4.5.2

The asset path setting in the project.xml is described in the first post. I have this behaviour in win7 firefox and chrome. (IE is not working with the latest lib versions also, but this has something to do with an invalid mp3 format, I’ll find out later :slight_smile: )

Oh, maybe it’s fixed since the last release

We’ll try and do a release soon

Cool, thanks a lot!
Looking forward for the next release then…

New versions are released

openfl upgrade

Let me know if that works better :slight_smile:


yes it’s fixed!! Thanks a lot :slight_smile:

A little hijacky, but now I’m getting the opposite problem. Since upgrading, fonts are no longer preloading for me, but loading just after Event.ADDED_TO_STAGE fires. Therefore, all the text I draw immediately is in Times New Roman until I redraw them. Is there more I’m supposed to be doing than including <assets path="assets/fonts" rename="fonts" include="*" /> in project.xml now?

Which browser? What version of OpenFL and Lime?

Thanks :smile:

I’ve tried it in both Chrome and Edge. It just started when I updated to OpenFL 4.5.3 and Lime 3.6.0.

Could you download this version of Lime, and see if it works differently?


(Download and run haxelib local lime-3.5.2-58-g6c79c41.zip from the same directory to install it)

If not, could you also try one or two OpenFL samples, to see if their fonts work?

openfl create AddingText
openfl test AddingText html5

openfl create PiratePig
openfl test PiratePig html5

Thank you :slight_smile:

PiratePig works fine, but AddingText renders in Times New Roman in HTML5 and Lime 3.6.0.

Trying with that version of Lime gives the following build errors with both my project and those examples:

C:/HaxeToolkit/haxe/lib/lime/3,6,0/lime/_backend/native/NativeAudioSource.hx:256: characters 34-44 : {+ pcmTell : Void -> haxe.Int64 } should be lime.media.codecs.vorbis.VorbisFile
C:/HaxeToolkit/haxe/lib/lime/3,6,0/lime/_backend/native/NativeAudioSource.hx:256: characters 34-44 : For function argument 'vorbisFile'
C:/HaxeToolkit/haxe/lib/lime/3,6,0/lime/_backend/native/NativeAudioSource.hx:263: characters 34-44 : {+ pcmTell : Void -> haxe.Int64 } should be lime.media.codecs.vorbis.VorbisFile
C:/HaxeToolkit/haxe/lib/lime/3,6,0/lime/_backend/native/NativeAudioSource.hx:263: characters 34-44 : For function argument 'vorbisFile'
C:/HaxeToolkit/haxe/lib/lime/3,6,0/lime/text/Font.hx:31: characters 2-11 : Build failure

Could you try Lime 3.6.1 that was just released?

openfl upgrade

You can also download from http://www.openfl.org/builds/lime if you prefer

It still doesn’t preload in 3.6.1.

Thank you,

You are right – I tried “AddingText” just now, and it didn’t preload. After the following change, it works properly for me. Would you be able to patch your local install, and see if it works for you as well? Thanks :slight_smile:

Awesome, that makes it work. Thanks a ton! :slight_smile: