Could not create SDL window


right after having trouble with building lime from sources, compiling openfl-samples worked for a short time.
But since I have tested to remove HAXE_STD_PATH and add it back to environment variable, I run into this problem
(I’ve also updated my windows 8.1 at the same time) when I compile to neko or windows:

Could not create SDL window: could not initialize OpenGL / GLES library
Could not create SDL renderer : Invalid window

So I am not able to use Lime/Openfl from git.:cry:

Any help? Thanks.

This sounds strange

I just made a fix that I think will mean HAXE_STD_PATH does not need to be set

I can’t think why it wouldn’t be able to get a window. Perhaps a clean build would help?

lime rebuild tools
lime rebuild windows -clean

No it doesn’t seem to work on first try. I’ve deleled the git folder of lime and redownloaded it and now it works again.
But as soon as I try to rebuild for angle, the error comes back.


lime rebuild neko -DLIME_SDL_ANGLE -clean
lime test project.xml neko -DLIME_SDL_ANGLE -clean
lime test project.xml windows -clean
=>error (why I’ve got the same error? I’m supposed to use opengl here and not angle…)
lime rebuild neko -clean
lime test project.xml neko -clean
=>no more error (now it looks that what you have suggested works, but I think sometimes -clean doesn’t work)

So, is angle broken?

Oh, ANGLE, yeah I haven’t tested that recently. Perhaps it is something with the upgrade to SDL 2.0.5, or perhaps there need to be newer/different Angle DLLs to work?

I just tried to use an older git version of Lime (just before the commit of SDL update) but I’ve got the same error as soon I’m trying to compile for ANGLE.
So maybe that’s my Windows update that broke everything because I’m pretty sure it worked 2 days ago.

I’ll try with a different computer.

I tried on the same computer lime 2.8 and ANGLE worked.

I’m still planning to try current current lime on a different computer. I’ll write here my results.

I tried again and the lime compilation worked on lime 2.9.1. I think I did a mistake when using git reset. I think I forgot the force key word in my git command the first time so I was still in last lime.