"Class not found : flash.utils.QName" when using SVG lib

When I’m trying to use SVG lib, a get this error when compiling to flash:

\haxe\std/flash/_std/Xml.hx:204: characters 25-55 : Class not found : flash.utils.QName
\haxe\std/flash/_std/Xml.hx:196: lines 196-203 : A return is missing here

Everything works fine when using HTML5 ie. What’s the problem? All libs are up to date.

Odd. According to Adobe, QName is a top level class. There’s no such thing as flash.utils.QName. However, Haxe puts the class under flash.utils, probably because it isn’t set up to handle top level classes on a per-platform basis.

There’s nothing wrong with this setup, as long as it works, which it does on Try Haxe. No idea why it fails in your case.

What version of Haxe are you using?

Thank for a replay. Unfortunately no changes in my case. As I said everything is updated. I’m using Haxe 3.1.3. I’m still looking for a solution.

I’ve solved the problem by wiping out haxe with everything else completely, and installing all the stuff again from the scratch. Thanks for your time and help =] It works now.