Can't build/test on windows - need halp!


I’m just trying to build a blank haxepunk project on windows. It runs fine on neko and android, but when i do a build or test on windows I get a linking error.

Link: ApplicationMain.exe
obj/msvc16-ncxp/d2e3f31c_NativeCFFI.obj : fatal error LNK1136: invalid or corrupt file
obj/msvc16-ncxp/d2e3f31c_NativeCFFI.obj : fatal error LNK1000: Internal error during IMAGE::Pass1

The interesting thing is that the file obj/msvc16-ncxp/d2e3f31c_NativeCFFI.obj is blank (0kb, nothing in it)

Would appreciate if someone could help me with this issue.


Update: I ran cmd in administrator and now it just trying to build src\ApplicationMain.cpp

Taking forever but it looks like the compiler is trying to do something as I can see its using the CPU in task manager. RAM is slowly climbing. Well I got 32gb and all night I suppose…

Cleaned and restarted build now its stuck on src/resources.cpp which is after the ApplicationMain file. If I stop the compiler and try again I get the error in the original post. Seems to be a problem with the C compiler from microsoft I think

Ok so I upgraded to visual studio 2015 and it actually works now… still takes a good while on that file though.

1 Like