Building sample project in Linux (Ubuntu) - Segmentation Fault

#1

Hello everyone.

I’m using Ubuntu 18.04 LTS and installed Haxe using the following command:

sudo apt-get install haxe

Then, I installed openfl and lime:

haxelib install openfl
haxelib install lime

After that I created a sample project using:

openfl create project

Finally, I tried to compile it running:

openfl build flash

And I’m getting the following:

/usr/lib/haxe/std/haxe/macro/Context.hx:210: characters 9-42 : Invalid input value
/usr/lib/haxe/lib/openfl/8,0,2/src/openfl/_internal/utils/ExtraParams.hx:13: characters 7-32 : Called from
–macro:1: character 0 : Called from
Aborted

I also tried building using the html5 target but got a segmentation fault.

Haxe version is 3.4.4.
OpenFL and Lime versions are 8.9.0 and 7.3.0, respectively.
I tried downgrading OpenFL and Lime to 8.0.2 and 6.3.1, but still got the same error.

Does anyone has clues on what is going on?

Thanks!

0 Likes

#2

Somehow your error points to OpenFL 8.0.2 though?

0 Likes

#3

Hey there.

Yes, that was the output of when I tried to downgrade the OpenFL version to 8.0.2.

The output is the same for 8.9.0:

/usr/lib/haxe/std/haxe/macro/Context.hx:210: characters 9-42 : Invalid input value
/usr/lib/haxe/lib/openfl/8,9,0/src/openfl/_internal/macros/ExtraParams.hx:12: characters 7-31 : Called from
–macro:1: character 0 : Called from
Aborted

Regards.

0 Likes

#4

Welcome to openfl
There are 2 nice articles covering it:
Start here https://www.openfl.org/download/
for example you didnt mention you did “haxelib run openfl setup”, also read the special linux-instructions

after that it should work.

0 Likes

#5

Something seems funny :confused:

Could you try installing Haxe again using the PPA?

sudo add-apt-repository ppa:haxe/releases -y
sudo apt-get update
sudo apt-get install haxe -y
mkdir ~/haxelib && haxelib setup ~/haxelib
0 Likes

#6

Hey Vega and singmajesty, thanks for the help.

Running “haxelib run openfl setup” didn’t work.

Following singmajesty instructions worked! (I had to run the commands to install openfl again: haxelib install openfl && haxelib run openfl setup)

Now I can compile the flash target. Unfortunately, I’m still getting segmentation fault for html5 target, which is the target I really want :confused:

Do you have any other suggestions?

0 Likes

#7

Could you try openfl test html5 -verbose and share the full output?

0 Likes

#8

The output is (the initial chars are the OpenFL logo):

.d88 88b. 888888b 888
d88P" "Y88b 888 888
888 888 888 888
888 888 88888b. .d88b. 88888b. 8888888 888
888 888 888 "88b d8P Y8b 888 “88b 888 888
888 888 888 888 88888888 888 888 888 888
Y88b. .d88P 888 d88P Y8b. 888 888 888 888
“Y88 88P” 88888P” "Y8888 888 888 888 "Y888P
888
888

OpenFL Command-Line Tools (8.9.0-LmimSi)

Initializing project…
Using project file: /home/lucas/Desktop/test/DisplayingABitmap/project.xml
Reading Lime config: /home/lucas/.lime/config.xml

Running command: UPDATE

  • Running command: neko /home/lucas/haxelib/lime/7,3,0/svg.n process /home/lucas/haxelib/openfl/8,9,0/assets/templates/default/icon.svg 192 192 /tmp/temp_16750581.png
    Segmentation fault (core dumped)
  • Running command: java -Dapple.awt.UIElement=true -jar /home/lucas/haxelib/lime/7,3,0/templates/bin/batik/batik-rasterizer.jar -d /tmp/temp_16750581.png -w 192 -h 192 /home/lucas/haxelib/openfl/8,9,0/assets/templates/default/icon.svg
    About to transcode 1 SVG file(s)

Converting icon.svg to /tmp/temp_16750581.png … … success
Segmentation fault (core dumped)

0 Likes