Bug: Error during Runtime, Could not Compile Shader, Shader.hx

I have been able to successfully compile the executables,

I tested the very basic examples like

Actuate, Bunny, SimpleOpenGl and so on.

**However the program does not run and throws an error regarding shader could not compile.

I looked at the web and they say it may be related to

#version //pragma in shader

they said, it should be in shader.hx or some file related.

How do we fix this?

By the way, these are some details i have:

haxelib list
actuate: [1.8.6]
BabylonHx: [0.0.0]
format: [3.1.2]
hxcpp: [3.2.193]
lime-samples: [2.6.0]
lime: [2.7.0]
openfl-samples: [3.3.1]
openfl: [3.4.0]
poly2trihx: [0.1.4]
swf: [1.9.1]

Hi, Could somebody put me to the right direction where to find the shader.hx or some other file involved?

Or at least, some way to debug it?

There are a few files named Shader.hx and GLShader.hx, but I don’t think they have what you want. Look at AGLSLParser.hx instead; that’s where the GLSL code is created.


Is this on a system without OpenGL 2? or running on forced software mode?

I tried it on Windows 7, its just could not run. I tried on Wine then run it on terminal, those were the errors I got. Its still working on Lime 2.6.0, but not on 2.7.0.

Hmm, well we’re switching to ANGLE on Windows (by default) and some other (improved) GL version checks, so this might work better in our next version release

I tried the latest Lime with ANGLE support (From Github), it does not work either. I believe OpenGl should work, I just could not find a way how.