BitmapData.draw just crashes

Wahou, OpenFl updates don’t like me those days.
Bug yesterday at work, and this morning bugs on my personal project.
This simple piece of code doesn’t work anymore:

var stamp:Sprite;
var bitData:BitmapData;

stamp = new Sprite(); 0xFF0000 ); 100, 100, 100, 100 );;

bitData = new BitmapData( 512, 512, false, 0xFFFFFF );
bitData.draw( stamp, null, null, null, new Rectangle( 0, 0, 300, 300 ) );

I tried different variation ( provide the optional parameters, cacheAsBitmap the stamp etc ), but my program just crash on windows or neko, while it obviously works fine on flash.
I tried to revert, but it didn’t work. I tried to reinstall FlashDevelop & haxelib ( it was time for a cleanup anyway ) and it still doesn’t work.

It seams weird something as simple wouldn’t work.
Is anybody having issues with that, or is it an issue related to my computer for some reason?

This is working for me

Are you using a development build, or did you install the new OpenFL/Lime versions released yesterday?

On the GL renderer, bitmapData.draw uses a framebuffer, which may not jive with certain graphics cards / OpenGL versions. I want to get this implemented using Cairo, that should make it safer for more systems. It was already using a framebuffer, though, before, so if the same system is not working, it makes me wonder if it is a bad build?

I tried with OpenFl 3.1.2 and 3.1.3.

And it used to work with 3.1.? ( I’m not sure, might even be 3.0.? )

Is there a tutorial somewhere on how to properly debug a neko / windows app?
Because it just plain crashes without any message.

As for my graphic card, I am on a Window 8 64 laptop with an integrated Intel GMA HD ( used to be switchable, but the other graphic card is fucked up ).
So yeah, definitely not a great graphic card, but although it is limited, I never had any issue with it.
The drivers run OpenGl 2.1

I just implemented bitmapData.draw using Cairo, it fixes the crash here on my laptop (also with an Intel integrated GPU) so good news :smile:

We’ll continue to optimize before we do the next release where this will go out :success:

Neat, thanks!
Is it in the dev repository?

Yeah, it’s in GIT now, it’s working so far in my tests

And finally I had time to test and it works for me, thanks again.