Application build error with openfl-webm (mac os)

I keep getting this error message when nearing the end of building my project:
Error : Could not load module [email protected]_vpx_codec_iface_name__0

I have haxelib and openfl-webm (0,0,4) installed in the default path on my mac os running 10.9.5.

Please help me :(. Any advice is appreciated!

Thank you!!

Are you sure this error is when building and not running?
Ie. if you do lime build mac does the error message appears?

This error looks like a missing ndll, one which should be named openfl-webm.ndll.

You are correct, it is in the running process of it. When i do lime build mac, the error message doesn’t appear.
When i installed the openfl-webm, in the ndll folder for mac, it doesn’t have the ndll you mentioned. It appears only in the “windows” folder of ndll. That is the missing ndll, i supposed.

Looks like it, it seems there is a build_mac.sh file in the openfl-webm folder, try running it to compile the ndll for mac.

When i run the the build_mac.sh, the result is:
$ bash /Users/s/openfl-webm/0,0,4/build_mac.sh
/Users/s/openfl-webm/0,0,4/build_mac.sh: line 2: pushd: project: No such file or directory
Error: Could not open build file “Build.xml”
/Users/s/openfl-webm/0,0,4/build_mac.sh: line 4: popd: directory stack empty

I’ve also tried running the script: haxelib run hxcpp /users/s/openfl-webm/0,0,4/project/Build.xml -Dmac and the result is:
g++ -Iinclude -Ilibogg/include -Ilibvorbis/include -Ilibvorbis/lib -I…/libs.src/libvpx -c -fvisibility=hidden -stdlib=libstdc++ -Qunused-arguments -O2 -I/Users/stevelim/hxcpp/3,1,39/include -DHX_MACOS -m32 -Wno-parentheses -Wno-unused-value -Wno-format-extra-args -DHXCPP_VISIT_ALLOCS -DHXCPP_API_LEVEL=0 -x c++ -frtti ./common/ExternalInterface.cpp -oobj/darwin/f07302ae_ExternalInterface.o
Error: clang: error: no such file or directory: './common/ExternalInterface.cpp’
clang: error: no input files
Although in the project file where Build.xml is located there is common folder with the file ExternalInterface.cpp

I think the script assume you are inside the /Users/s/openfl-webm/0\,0\,4/ folder.

I tried moving the whole “project folder” to a different folder to try out it if the /0,0,4/ folder is the cause but still get the same error.

You might be able to do “lime rebuild openfl-webm mac” if it has a standard project/Build.xml file

Thank you Singmajesty. I will try it n report it. Crossing my fingers.

Didn’t work. It came out with similar error message

To see I tried it, linux though with g++, three errors I had to fix but otherwise it compiled.
So I wonder if clang or mac does something different.
I’ll try to make hxcpp use clang and retry.

No even with clang it works.

It’s really strange, I wonder why on mac it doesn’t find the ExternalInterface.cpp file.

Well the only thing now would be to find someone else with a mac to try it and see if the problem comes from your computer or the lib…

I have no idea. I tried both on my macpro desktop and macpro laptop. Tried moving the whole openfl-webm folders as well as renaming them but still can’t find the cpp file.

Just to be sure when you do ls -l common/ExternalInterface.cpp does the terminal find the file?

will check on it later tonight.

Doesn’t work :(. I think i will just try using other ways. Thank you folks for trying to help me.

If the file isn’t there then it’s not as surprising that clang can’t find it.

Maybe try getting the lib from github: https://github.com/soywiz/haxe-openfl-webm
download zip then haxelib local haxe-openfl-webm-master.zip.

Hey guys,

I just gave it a try. It had errors about not finding “vpx” headers, and some other things which I was just able to resolve. I have not tried to use the library, but “lime rebuild haxe-openfl-webm mac” is working now.

Here is the pull:

You can also just download the changed source from here:

the lime rebuild works

The pull request has been merged, so the patches should be available in the main repository now :slight_smile: