Android x86 support?

Is there any news or update for android x86 support?

it’s would be a shame if OpenFL didn’t support these device since device like ASUS ZenFone are gaining momentum.

Try to add

<architecture name="x86" if="android" />

into the project.xml


I tried to add the code on BunnyMark and PiratePig ,
the build was successful but, it’s blank when i open it on Genymotion Emulator (haven’t tried it on real device yet)

But when i tried to add this code on SimpleBox2D sample, it works !!!

Thank you very much for your assistance, i am currently investigating what makes the samples(other than simplebox2d) not working correctly.

Try the BitmapData test.

@tvalentius do not trust 100% on Genymotion. i tried to use it like 2 years ago with openFL and nothing worked (when same example worked on the real device and official emulator). and by your experience, things didn’t improved much since then :stuck_out_tongue:

I tried with

<architecture name="x86" if="android" />

in my project.xml file but this is still the arm compiler that is used…

Any idea on what might be the problem?

Probably there is regression in newer lime version. Quick debugging: <architecture> tag is parsed correctly in ProjectXMLParser.hx, but in AndroidHelper.hx in build() there is only ARMV7.

@singmajesty ?

This was indeed a bug, resolved in

Is this already fixed in prod version (lime 3.6.0) or only on the dev git one?

EDIT: Yes it is. Just forced a lime and openfl update and this is working now. Thanks

1 Like