Android, "failed to find Build Tools revision 24.0.1"

Hi, since I upgraded openFl 3 to 4, I can’t build to Android.

Here a screen with the place I’m stuck :

Does anyone know what’s happening ?

Check under Export/android/debug/bin. Does it point to the correct place?

I had this exact error after updating last tuesday. it was the first in a chain of errors i had to resolve to be able to build to android after updating to openfl 4.2.0 , lime 3.2.0.
Trying to remember the fix’s, i remember uninstalling build-tools 24.0.2 and breaking AndroidSDK completely, fixing the androidSDK client which wouldn’t load, ensuring i had exact version of build tools it was looking for 24.0.1, I also remember updating androidSDK to included Tools 25.2.2 (which i see in your list already) .
after that once that error subsided, the chain of errors were fixed by (amungst other things that i can remember) updating the JavaJDK from 1.7 to 1.8 (jdk1.8.0_101) - and editing the path to it in myC:/Users//.hxcpp_config.xml setting file manually. (the java update was required by Gradle, which the latest version uses instead of Ant to build to android), good luck !
(edit - i remain with 24.0.2 uninstalled, which i think was the first fix)

Updated java and fixed pathes, and it worked, thanks !

Had the same problem, installing 24.0.1 and updating java package, then ‘openfl setup android’, to change path, thjs worked

For anyone else stuck on this, I just downloaded the 24.0.1 build tools directly with via and extracted it into C:\Development\Android SDK\build-tools\24.0.1

Can swap out “windows” with “linux” or “macosx” for your corresponding OS.

Special thanks to


Also note that I downloaded JDK 1.8 as suggested above.

1 Like

Just for reference, what java version did you have to upgrade to ?
Was it also “JavaJDK from 1.7 to 1.8” ?

I downloaded JDK version 1.8, I’ll edit that into my post

1 Like