Air target, adt compilation error with iOS + Objective-C


#1

NOTE: The error does NOT occur when transpiling to Air, but when using adt to export the haxe-generated air-swf to ios while also converting it into objective-c.

The folliwing error is logged twice and then the adt compilation fails.

Error #1053: Illegal override of removeWindow in lime.app.Application.

Background:
We tried to export our ios project with haxe. We converted the as3-air-project to haxe.
Then we used our old ios export scripts which are based mainly on FlashDevelop’s templates and were adjusted by us slightly over the years.

This has worked very well for the interpreter builds (which are NOT converted to objective-c, they stay flash). However, for release it has to work also with objective-c.

Has anybody some idea what might go wrong there? Or is there maybe some better way of exporting air to ios with openfl by now?

Thanks


#2

Some more Details:

The full output of the Run.bat with “ios-debug” is:

Set "AIR_SDK" to "C:\Users\SomeUserName\AppData\Local\FlashDevelop\Apps\ascsdk\28.0.0"

Packaging application for debugging on iOS

Packaging: dist\mau-mau-debug.ipa
using certificate: ..\_cert\development\app_signing\iphone.p12...

adt -package -target ipa-debug -connect  -storetype pkcs12 -keystore "..\_cert\development\app_signi
ng\iphone.p12" -storepass OUR_SECRET_PASSWORD -provisioning-profile ..\_cert\maumau_dev.mobileprovision
  "dist\mau-mau-debug.ipa" "application.xml" "Assets.car" "purposeStrings.xml" -C bin2 . -C "splashs
creens/compressed" . -extdir ../_extensions
C:\somesecretpath\iphone\maumau\dist\AOTBuildOutput4755858901458368468.tmp\ABCFiles\AOTB
uildOutput-0000000111.abc:
Error #1053: Illegal override of removeWindow in lime.app.Application.
C:\somesecretpath\iphone\maumau\dist\AOTBuildOutput2421507033828166347.tmp\ABCFiles\AOTB
uildOutput-0000000111.abc:
Error #1053: Illegal override of removeWindow in lime.app.Application.
Compilation failed while executing : compile-abc
adt -installApp -platform ios -package "dist\mau-mau-debug.ipa"
Cannot find <ipa-file> dist\mau-mau-debug.ipa

APK setup creation FAILED.

Troubleshooting:
- did you build your project in FlashDevelop?
- verify AIR SDK target version in application.xml

Press any key to continue . . .

And it seems not to be the fault of the targetted AIR SDK. We tried multiple SDK versions.

in our project xml we defined:
<app swf-version="28" />
Whereas swf-version actually seems to mean air-sdk version here. There seems to be an offset of 11 automatically applied to it.


#3

Forget it. This problem does not occur for my colleague, who has the same setup.