V8.4.0 (08/08/2018): Compiling errors after update


#1

I probably shouldn’t have jumped the gun…

Updated everything today and haxelib list yielded this:

actuate: [1.8.7]
as3hx: [1.0.6]
box2d: [1.2.3]
gsap: [1.0.4]
hxcpp: 3.4.188 [4.0.4]
layout: [1.2.1]
lime-samples: 6.2.0 [7.0.0]
lime: 6.4.0 [7.0.0]
openfl-samples: 6.0.0 [8.4.0]
openfl: 8.2.2 8.3.0 [8.4.0]

openfl setup yielded this:

lime is up to date
hxcpp is up to date
lime-samples is up to date
openfl-samples is up to date
actuate is up to date
box2d is up to date
layout is up to date
Do you want to install the "openfl" command? [y/n/a] ? y
Password:
Set MAC_USE_CURRENT_SDK to 1

created new NyanCat project like so… openfl create NyanCat

openfl test html5 yielded this:

Called from openfl/_internal/renderer/opengl/GLGraphics.hx line 43
Called from openfl/display/BitmapData.hx line 150
Called from a C function
Called from openfl/display/BitmapData.hx line 300
Called from lime/graphics/Image.hx line 600
Called from lime/_internal/graphics/ImageDataUtil.hx line 394
Called from a C function
Called from /usr/share/haxe/std/neko/Lib.hx line 42
Uncaught exception - load.c(237) : Failed to load library : lime.ndll (dlopen(lime.ndll, 1): image not found)
Error: Could not process asset libraries (swf)

HELP!
ALL of my projects are yielding the same errors!


#2

Temporary “solution”…

I used haxelib set [project-name] [version] to set the “current” version to the previous version.
To be safe, I did this for ALL the updates, including the samples.

Here’s a list of the projects I had to (re)set:

hxcpp: 3.4.188 [4.0.4]
lime-samples: 6.2.0 [7.0.0]
lime: 6.4.0 [7.0.0]
openfl-samples: 6.0.0 [8.4.0]
openfl: 8.2.2 8.3.0 [8.4.0]

RESULT:

actuate: [1.8.7]
as3hx: [1.0.6]
box2d: [1.2.3]
gsap: [1.0.4]
hxcpp: [3.4.188] 4.0.4
layout: [1.2.1]
lime-samples: [6.2.0] 7.0.0
lime: [6.4.0] 7.0.0
openfl-samples: [6.0.0] 8.4.0
openfl: 8.2.2 [8.3.0] 8.4.0

NOTE the version numbers in brackets…


#3

Do all your projects use SWF assets?


#4

For now, @singmajesty, yeah…

It’s just a bunch of banner ads, but I have a ton of them that I have to convert from Flash to HTML5 for my portfolio website.

(I pushed my employers really hard to migrate early on, but they pushed back harder.
How long has this been going on…? e.g. The conversion I’m working on now used AS2!!!)

Right now, I’m trying to figure out gradient masks…

I know that gradient masks are a work in progress, but if you know of any step-by-step tutorials on how do deal with it, it would be SOOOO appreciated!

(I know this is the wrong place to ask that question; still trying to figure out a way to word a new Help topic properly… reminder: I am a total Noob Boob! LOL!


#5

If I remember correctly to use gradient masks you need LAYER blendmode, but it is still unsupported, right @singmajesty?


#6

If I understand right, you mean being able to do alpha < 1 && alpha > 0 in masking, rather than simple on/off?

This is on the TODO list, this might be supported our software targets, but this is going to require a custom shader on OpenGL. We’re about 8 out of 10 steps to having this work