Resizable = false not working in macos


#1

It works great on Windows, though if I have that in the xml and compile it on macos it still allows me to move the edges of the window. Doing something wrong here, missing another option for macos, something else ?


#2

SDL is the library that handles our windowing. When we create, we should be passing SDL_WINDOW_RESIZABLE when we want a resizable window, or not if we want it to be a fixed size. Perhaps there is a possible regression in SDL’s behavior on macOS, did this used to work in a previous version of Lime?

You could try setting stage.window.resizable = true then stage.window.resizable = false at runtime, and see if it makes any difference.


#3

I didn’t try it earlier to this on macos. Going to try the runtime workaround when I have the machine back.
Thanks.


#4

That fixed it, thanks @singmajesty.
I never tried setting up a window like that in previous versions of Lime.