openFl 5.0.0 update problem


#1

I just update openFl(5.0.0) and lime (4.0.2). I create new project in FlashDevelop and get following error:

When change lime to 4.0.2 it said

Error: OpenFL 5.0.0 is not compatible with Lime 4.0.2 (version 4.1.* is required)


#2

It’s hard to read the screenshot, does it say version 3.5 is required?

Does your project.xml use <haxelib name="openfl" />, or does it request a specific version?

Does your project include any other haxelibs, which may specify an exact version of OpenFL or Lime, rather than using the versions set on your system?

What does haxelib path openfl and haxelib path lime return? Does it appear to be the current versions?


#3

This is workflow of error:

  1. I create new project in FD, run it with flash target and it was OK
  2. upgrade openfl and lime
  3. compile again and get errors

I use only <haxelib name="openfl" />
And path suggest to newest version of libraries


#4

I also tried to compile some of my old project in HaxeDevelop and get same error.

OK, It’s my fault. lime should be 4.1.0 and it wasn’t set automatically after upgrade.
It’s compilable in both FlashDevelop and HaxeDevelop


#5

Unfortunately I am going through same issue, I have a fresh copy installed and lime is by default installed 4.1, everything is new… strange that still openfl sample throw the same error:

Error: OpenFL 5.0.0 is not compatible with Lime (version 4.1.* is required)

#6

I installed openfl 4.9.2 and it says: Error: OpenFL 4.9.2 is not compatible with Lime (version 4.0.* is required)

I installed Lime 4.0.3 and still no luck :frowning:


#7

This cycle of errors can occur if you have something such as:

<haxelib name="openfl" />
<haxelib name="openfl" version="4.0.0" />

First OpenFL (latest) is pulled in. The version check passes, the tools record OpenFL as version “5.0.0”

The second (older) OpenFL is pulled in. The version check does not pass, because the tools still have “5.0.0” recorded as the version, which fails the older include.xml version check

The next version of Lime has a warning (and fix) for this multiple import problem, as well as smarter “wildcard” version imports for OpenFL pulling in Lime, which should help :wink:


#8

Thanks @singmajesty

I am attaching screen for reference, I think something is wrong…


#9

What does haxelib path lime return?


#10

-L lime/4,1,0/ndll/
–macro lime.Lib.extraParams()
/usr/share/haxe/lib/lime/4,1,0/
-D lime


#11

Are you able to try OpenFL 5.1.1 and Lime 5.0.2 that were released?


#12

Error: Lime 5.0.2 is not compatible with Haxe 3.0.0 (version 3.2.0 or higher is required)


#13

What Haxe version do you have? We support Haxe 3.2.1 or Haxe 3.4.2 at the moment


#14

I started receiving this similar error since lime 5.0.0 and openfl 5.1.0 too

Error: Could not find haxelib “lime” version “5.0.*”, does it need to be installed?

everything was building fine before. Im using haxe 3.4.2, on windows 7


#15

Do 5.0.2 and 5.1.1 work?


#16

Still the same problem. Once I see that error, even if I downgrade to the previously working versions of lime and openfl, I have to reinstall haxe to get them working again


#17

Could you try two things for me?

Run:

haxelib path lime:5.0.2

and also

neko /usr/share/haxe/lib/lime/5,0,2/tools/haxelib.n path lime:5.0.*

or

neko C:\HaxeToolkit\haxe\lib\lime\5,0,2\tools\haxelib.n path lime:5.0.*

…depending on where Haxe is installed, and see what they return. Thank you!


Possible SVG and colorTransform workaround idea
#18

This information will help us fix this feature for future releases. In the meantime, you can also install the OpenFL 5.1.2 release made today, which uses the older style of including Lime in order to avoid this problem


#19

Here are the two messages

-L C:\dev\HaxeToolkit\haxe\lib\lime/5,0,2/ndll/
–macro lime.Lib.extraParams()
C:\dev\HaxeToolkit\haxe\lib\lime/5,0,2/
-D lime=5.0.2

Error: Invalid parameter : 5.0.*

Edit: If I change the second commands version to 5.0.2, it returns the first result also.


#20

Have installed haxe 3.4.2 and haxe version request is gone, but there are different issues now for e.g.

openfl test html5

throw following

chmod: changing permissions of ‘/usr/share/haxe/lib/lime/5,0,2/templates/bin/node/node-linux64’: Operation not permitted

events.js:72
throw er; // Unhandled ‘error’ event
^
Error: listen EADDRINUSE
at errnoException (net.js:904:11)
at Server._listen2 (net.js:1042:14)
at listen (net.js:1064:10)
at net.js:1146:9
at dns.js:72:18
at process._tickCallback (node.js:419:13)
at Function.Module.runMain (module.js:499:11)
at startup (node.js:119:16)
at node.js:906:3