Haxe 3.4.2 installer script for Linux


#1

I’ve updated the Haxe install script for Linux:

http://www.openfl.org/builds/haxe/haxe-3.4.2-linux-installer.tar.gz

If anyone tests this out, please let me know if there are ways we can improve it, and if it works properly on your distribution :smile:


#2

Works fine on Kubuntu 16.10!


#3

sweet, I’m going to test this when I get home!


#4

404 … Its gone! Perhaps the link is just broken? Is there still a script? Also, just a plain list of all dependencies - including version numbers - can be helpful. Especially if you’re into exotic Linux distro’s.

Also some questions would be which version of OCaml best to use? And are there any issues with kernel versions? And last will it run on all cpu’s? i686, x64, arm-v7, arm64 and mips?


#5

someone send me the rpi ndll


#6

With some googling I’ve just found this script. It’s based on Raspberry Pi and it suggests these dependencies: (although I doubt that some of these will be 100% necessary (Eg. imagemagick))

libgc-dev 
bzip2 
git-core 
make 
gcc 
g++ 
gnuplot 
glade 
imagemagick 
libusb-dev 
python-usb 
python-lxml 
python-wxgtk2.8 
speech-dispatcher 
libgnomecanvas2-dev 
m4 
libsdl1.2-dev
ocaml 
ocaml-native-compilers

This post from 2015 suggests that OCaml 3.12.1 is the main targeted version. But the post is kind of old and version: 4.01.0 was already mentioned also the latest version is: 4.06.0. So if anyone can still recommend a version.!? That would be appreciated…


#7

After installing OCaml 4.01.0 on a C.H.I.P. linux system and cloning the Haxe repo. I get this output when executeing make:

/usr/bin/ocamlopt: unknown option `-safe-string'.

If I then remove that commandline switch from the Makefile:
<source>/libs/extlib-leftovers/Makefile

The output is this:

File "rbuffer.ml", line 37, characters 19-24:
Error: Unbound type constructor bytes
Makefile:25: recipe for target 'extlib-leftovers.cmxa' failed

I have no clue how to fix this! Perhaps I need to install a different OCaml? (3.12.1?)