Standard Library Not Found on any openfl build command

Up until now I’ve been using FlashDevelop to build openfl projects without incident.
However, I’ve noticed if I try and use the command prompt, executing the exact same command by FlashDevelop in my project directory, I get ‘Standard library not found’.

Just a simple ‘openfl test flash’ returns the same error. I haven’t been able to compile anything with openfl outside of FlashDevelop.

I have HAXEPATH correctly set and I’m running Windows 10 64bit.
I tried setting HAXE_STD_PATH to the haxe/std directory but still no luck.

Any ideas?

Can you reproduce the error with a sample project?

> openfl create DisplayingABitmap
> cd DisplayingABitmap
> openfl test flash

Executing the above I still get:
‘Standard library not found’

Sounds like a strange install? Perhaps FlashDevelop sets its own environment variables

Very odd.
I had downloaded the Haxe binaries instead of using the installer. All my environment variables were correctly configured but it wouldn’t run openfl from the command line for some reason, everything else was fine.
So I downloaded and executed the Haxe windows installer, tried building with openfl and all seemed fine.
I uninstalled it, put everything back to what it was, and now the original Haxe/Openfl works!
Is there a dll in my Windows directory after running the installer perhaps?


D’oh, I’m and idiot. I’ve worked out why it was acting weird. A few weeks ago I tried making some symlinks with windows, just out of curiousity. I created a load and put them in a PATH directory to give me command line access to a load of helpful command line programs, and I accidentally included haxe.exe and haxelib.exe. These took priority over HAXEPATH I guess.
This might be the reason I was struggling to compile CPP a few weeks ago also.


Just checked, nope. HXCPP > 3.2.180 issue still persists. I have to use 3.2.102 otherwise I get ‘Process creation failure : cl.exe’