[Solved] Linux MacroShader error

Hi, on Linux Kubuntu 14.04 with recent non-dev version of haxe, lime and openfl I got following problem while trying to build openfl PiratePig:

Running command: BUILD
 - Copying library file: /home/az/haxelib/hxcpp/3,2,205/bin/Linux64/std.dso -> Export/linux64/cpp/bin/std.dso
 - Copying library file: /home/az/haxelib/hxcpp/3,2,205/bin/Linux64/regexp.dso -> Export/linux64/cpp/bin/regexp.dso
 - Copying library file: /home/az/haxelib/hxcpp/3,2,205/bin/Linux64/zlib.dso -> Export/linux64/cpp/bin/zlib.dso
 - Copying library file: /home/az/haxelib/lime/2,8,3/ndll/Linux64/lime.ndll -> Export/linux64/cpp/bin/lime.ndll
 - Running command: haxe Export/linux64/cpp/haxe/release.hxml -D HXCPP_M64
/usr/share/haxe/std/neko/_std/EReg.hx:33: characters 11-61 : Unsupported escaped char 's'
<builtin>:1: character 0 : Called from
/usr/share/haxe/std/neko/_std/EReg.hx:22: lines 22-204 : Called from
/home/az/haxelib/openfl/3,5,2/openfl/_internal/macros/MacroShader.hx:29: characters 27-165 : Called from

and compilation stops.
MacroShader got some regex in this line.
ActuateExample, HerokuShaders and BunnyMarks works (dont have such errors).

it works fine for me,

haxelib list:

actuate: [1.8.6]
format: [3.1.2]
hxcpp: [3.2.193]
lime-samples: [2.6.0]
lime: [2.7.0]
openfl-samples: [3.3.1]
openfl: [3.4.0]
swf: [1.9.1]

GCC 4.9.2 x86_64

1 Like

Thank You:) I’ll check those versions:)

Topic solved in the last posts here:
which actually is:

# cd /usr/lib
# sudo ln -s libneko.so.0 libneko.so

latest versions of lime and openfl works :slightly_smiling:
Best regards, Ret

How did you install Neko? Did you use our install script, or did you use another method?

I followed info on haxe main site for Ubuntu:

added ppa:haxe/releases and run commands given.

Same problem still exists today (when installing haxe/neko via ppa://haxe/releases), same solution still works.

1 Like

Got the same problem and gone ahead with same solution with an updated neko version file.

# cd /usr/lib
# sudo ln -s libneko.so.2 libneko.so

just instead of libneko.so.0 I have libneko.so.2

Hope that helps someone.