Problems installing 3.0.0-beta (win 7)

This is what I’m getting:

>haxelib run openfl setup
Downloading lime-2,2,
Download complete : 80085332 bytes in 494.4s (158.1KB/s)
  Created project/
swf is up to date
Called from ? line 1
Called from CommandLineTools.hx line 1343
Called from CommandLineTools.hx line 25
Called from CommandLineTools.hx line 94
Called from CommandLineTools.hx line 1354
Called from utils/PlatformSetup.hx line 406
Called from utils/PlatformSetup.hx line 483
Called from utils/PlatformSetup.hx line 1851
Called from /usr/lib/haxe/std/neko/_std/sys/io/File.hx line 63
Called from /usr/lib/haxe/std/neko/_std/sys/io/File.hx line 54
Uncaught exception - [file_open,C:\HaxeToolkit\haxe\\lime]

Any idea on what can be causing this?

(I’m on haxe 3.2.0-rc2)

It looks like it’s trying to enable the “lime” command, but the command is already enabled and another program is already using it. This command takes the form of a binary file named “lime,” and a batch file named “lime.bat,” in your C:/HaxeToolkit/haxe/ folder. Delete both of those, and the setup process should work.

Though if the files really are in use, you may not be able to delete them without restarting first.

Thanks @player_03, maybe that would have worked as well.

I’ve fiddled with haxelib a bit and resolved the issue before reading your answer. Not sure what was exactly though, I tried a bunch of things: cleaned up some unused libs, called haxelib selfupdate again, removed lime folder, etc.

Anyway now any simple openfl application (like the DisplayingABitmap demo) crashes when targeting neko and cpp. No error messages are printed. They work fine if I use -Dv2.

Here’s what happens if I target html5 instead:

c:\HaxeToolkit\haxe\openfl-samples\2,2,2\DisplayingABitmap>openfl test project.xml html5

Any ideas about these ones?

I reported that one

it’s because of a patched file that’s not up to date.

Hi @ibilon, and thanks for the fast response!

So that explains the html5 side of my issues, what could be the cause of the other ones?