OSX el capitan compilation errors

I have upgraded to el capitan and now there is no way to compile.
I use IntellIj and if i compile from program i get the next error for all platforms:
Information:sh: neko: command not found
But i tested i got neko command from console
From console if write:
openfl test flash and it works
but for ios i write openfl test i got:
chmod: Unable to change file mode on /usr/local/lib/haxe/lib/lime/2,6,7/templates/bin/ios-sim: Operation not permitted
if i use sudo i got:
This is the first time you are runing haxelib. Please run haxelib setup first

Thanks for replies

You could try running sudo chmod a+x /usr/local/lib/haxe/lib/lime/2,6,7/templates/bin/ios-sim and then try running openfl test again.

You are my hero!!! Thanks a lot tanis!!!

1 Like

I got this error in IntelliJ as well

Information:sh: neko: command not found

How can I fix that?

With version 15 of intellij i can not fix, i just use the console of the intellij and build/compile the app by example:
sudo lime test fliash -debug

Hmm, it’s annoying not being able to build nor debug in IntelliJ. Is there any alternative IDE on Mac that can work better?

I figured out. Check the “Skip compilation” flag in module setting fixed it. It works fine with breakpoint for flash target.