Not a valid win32 application on windows xp

When running “lime test neko” on windows xp (for example, using the DisplayingABitmap sample) I get a windows error saying “Not a valid win32 application”.

Any idea what might be causing this ? I’m using the latest version of everything …

Any other samples do that too?

What about a native application? lime test windows

Just tried the BunnyMark sample - same thing.

Busy compiling for windows … Taking a while (old laptop)

The application opened with lime test windows but it died immediately, saying “DisplayABitmap.exe has encountered a problem and needs to close” …

You wouldn’t happen to have access to another windows post xp by any chance?
If so, could you try the exe on it? And try compiling the sample on it and then test it on xp.


So the XP compiled .exe does the same thing on my new, Windows 7, machine - “Not a valid win32 application”.

Then when I compiled on new computer and bring it to old it runs but dies, with the “.exe has encountered a problem” error …

Same error too. It is happened after installation some of the Haxe dev build (I do not remember exactly) and it can be fixed (again - I do not remember exactly) by full reinstall Haxe (and Lime maybe) to stable version.

T1mL3arn: I’m not using the haxe dev build - Using standard 3.1.3 right off the website …

Like I said - I do not remember exactly, when this problem is happened for me :sweat_smile:

No, I understand. I’m going to try changing the haxe and openfl versions and see if that helps. Thanks for the suggestion.

Strange, though - why would it build differently with the same code base ? Interesting … I wonder how one might go about figuring out which … System calls might affect the nature of the exe ? I should do a comparison of the executables produced on the different machines …

Different Visual Studio version?

I am not changed VS ( I have 2010 Express), but may be I am changed c++ redistributable. This may be the reason?

I hadn’t considered that … on the xp laptop I’m using 2010 express as well. Redistributable ?

I’m thinking maybe I should give up trying - Windows XP isn’t even supported anymore. It’s just expensive upgrading my laptop to windows 7 … Maybe I should use Linux ?

What’s the best way to use an old laptop to develop for OpenFL ?

Have you guys tried using Lime from the source, and doing lime rebuild windows rather than using the haxelib releases of Lime?

There may be subtle things in the builds that make a difference between Windows XP support and not, which might be based on the compiler I am using in the build server

I updated right now my lime-dev and openfl-dev, but error is still here.

Sorry - Left the forum for a bit. Will try build lime from github when I get home.


I’m not sure I understand - Using lime from the source ? Does the version that comes down with haxelib … Does that not include the source ? I thought the haxelib was just a tag from the github repo ?

… By “from the source” I assume you mean saying haxelib git lime ? And then … saying lime rebuild windows then builds the … library binaries ?

Strange - I never realised that rebuild mean “build the lib” …

Ok, my bad: I see it now - On the github page there is an explanation for what “Build from Source” means … Though it kinda looks like what I described … except setting dev instead of git … Anyway. Busy …

Ok so I did the rebuild but this error happens when I lime test neko (and same thing with lime test windows)

C:\dev\openfl\DisplayingABitmap>lime test neko C:/HaxeToolkit/haxe/lib/openfl/3,0,3/openfl/display/Stage.hx:168: lines 168-1611 : Field onTextEdit needed by is missing C:/HaxeToolkit/haxe/lib/openfl/3,0,3/openfl/display/Stage.hx:168: lines 168-1611 : Field onTextInput needed by is missing C:/HaxeToolkit/haxe/lib/openfl/3,0,3/openfl/display/Stage.hx:168: lines 168-1611 : Field onWindowEnter needed by is missing C:/HaxeToolkit/haxe/lib/openfl/3,0,3/openfl/display/Stage.hx:168: lines 168-1611 : Field onWindowLeave needed by is missing

Also you need to update openfl.