Lime Extension template won't compile


I am new to creating extensions and am running into some issues. I kind of get that there is some issue with package naming and class naming, but it throws some additional errors connected to the ant/build.xml. Any advice to where I start fixing?

    [javac] Compiling 4 source files to C:\dev\sandbox\HelloExtension\bin\android\bin\deps\sampleextension\bin\classes
    [javac] C:\dev\sandbox\HelloExtension\bin\android\bin\deps\sampleextension\src\org\haxe\extension\ class Sampleextension is public, should be declared in a file named
    [javac] public class Sampleextension extends Extension {
    [javac]        ^
    [javac] C:\dev\sandbox\HelloExtension\bin\android\bin\deps\sampleextension\gen\org\haxe\extension\sampleextension\ package org.haxe.extension.sampleextension clashes with class of same name
    [javac] package org.haxe.extension.sampleextension;
    [javac] ^
    [javac] 2 errors

C:\devTools\AndroidSDK\tools\ant\build.xml:597: The following error occurred while executing this line:
C:\devTools\AndroidSDK\tools\ant\build.xml:716: The following error occurred while executing this line:
C:\devTools\AndroidSDK\tools\ant\build.xml:730: Compile failed; see the compiler error output for details.

Find the source file, and capitalize the first letter.

Did that, got the same error

Clear your bin folder to force it to load your new file. (Or if you don’t want to delete everything, just delete the deps folder.)

Ah cool, forgot to make a clean build of the extension aswell after renaming. Clean building the extension and then the project solved it. Thanks a bunch!

Also just stumbled across an article on your blog:

good job at explaining what the individual files are needed for!

I don’t know if you needed to rebuild the extension - rebuilding normally affects C++ files, not Java files - but it certainly couldn’t hurt. Anyway, I’m glad you figured it out.