HTML5 Firefox Sound Issue, Music and sounds playing twice!

I’ve just updated to Haxe 3.4.4, OpenFL 6.5.0, Lime 5.8.2, and after a few days have my code running again.

I’m continuing to experience a major problem with sound in Firefox (latest version 57) when i target HTML5

I brought it to the forums back in march HTML sound woes, after Howler replaces SoundJS but it’s still ongoing,

The Issue is easily reproducible by following these these steps:

  1. Open the PlayingSound example code

  2. Edit line 43 from “position = 0” to. “position = 60”

  3. target HTML5 , and open in Firefox.

What you will be hearing is the .ogg file being played twice simultaneously ! the same music but with one instance of it shifted by 60ms .

Now a quick question, has anyone else noticed that whenever they test in firefox, the volume is higher for all sounds and music ? could it be that even when started at position 0, every sound is occurring twice simultaneously and the only symptom is the sound seeming louder ?

I just found a workaround:

It is similar to one we had before, except that the play starting position works properly

I’ve committed a patched version of Howler here:

Thanks for letting me know about this :smile:

hi, I’m still having this issue with the latest howler.min.js, and also the latest 2.0.5 version

linking to the IE howler thread, as i hadn’t originally realised it was related

The patch I made fixed the “PlayingSound” sample, I tried giving it a new start position (or a different sound with less echo) and I could hear it play twice, once at the start position, once at the position I requested. My changes resolved this issue and it played only once

hummm, strange that i’m still experiencing it.

I’ve double checked by this method.

I’m using your recent edit of goldfire/howler.js , having placed the file src/howler.core.js in my project folder.

I’ve applied the adjustment to line 2204 (from the IE critical error thread HTML5 - Internet Explorer Critical error (howler) )

I’ve renamed the file downloaded howler.js file howler.core.jgranick.17.11.2017.29.11.2017.js , to ensure that i can check i am using the correct .js file is loading when i test. I’ve adjusted my html project index.html to use this .js for howler instead of the howler.min.js, and deleted howler.min.js from the folder. I’ve emptied my browser cache also.

I’ve tested with a a different .mp3, (that’s much more obvious than stars .mp3 when it overplays), and double checked in the debug Network tools that the version of howler being loaded is the obscurely named one i’m trying to test with.

After all that, In Firefox i’m still experiencing the double play issue when i set position to be a few second in to the mp3 rather than leaving it at zero.

(I’ve written all my steps, as i don’t think this could just be me)

Oh, howler :frowning:

I’m surprised there aren’t more people who are running into the same problem

I have same problems.
For IE users i just disabled FX sounds, but double start music bug in FF is still actual for me. And i’m waiting for patch =)

Looked into this further ! your workaround fix of Howler on the 17th does work once i corrected the typo.

line 186 should read

if (self._initSuspended && self.ctx && self.ctx.state != 'suspended') {


Thanks, I did the changes using the Github web interface by hand, and guess I messed it up a little :blush:

I patched my branch, and just updated Lime with the patches as well