Fresh project - Android crash - No error messages


I recently came back to Haxe/openfl from a long time away.
I started out by creating a new project and setting up the android platform.

After building the app on the device, it immediately crashes leaving no traces for debugging.

I’ve tried verbose, debug etc. nothing useful comes out of it. This is a fresh new project which only contains the following:

Total time: 9 seconds
/system/bin/sh: can't create C:UsersLPC-AppDataLocalTemp/temp_13093254: No such file or directory
5137 KB/s (3950896 bytes in 0.751s)
        pkg: /data/local/tmp/Lab-debug.apk
Starting: Intent { act=android.intent.action.MAIN cmp=xx.xx.lab.Lab/.MainActivity }

package xx.xx.lab;

import haxe.Json;
import openfl.Assets;
import openfl.display.Sprite;
 * ...
 * @author Linus Jakobsson
class Main extends Sprite 
    private var startMenu: StartMenu;
    public function new() 
        var getJson = Json.parse(File.getContent('json/stats.json'));
        trace('this is a test' + getJson.employees[0].firstName);


Any pointers?

Try logcat.

Yeah, try openfl test android -verbose for more data to see if it tells you why it crashes. Also, have you tried openfl create DisplayingABitmap && openfl test DisplayingABitmap android or some other OpenFL sample? That should be a good reference as a sanity check :slight_smile:

Yeah, verbose hasn’t returned anything other than what was posted above, sadly :frowning:

I’ll go ahead with the sanity check after I’m home from the office… Might be needed :wink:

create DisplayingABitmap runs just fine on the android device.

This is very strange.

Located the problem -


icon path="assets/openfl.svg" /


icon path="assets/img/openfl.png" /

For some reason it doesn’t like the svg file that’s initated at the start of the project.