Android "string types not allowed at..." build error is back

String types not allowed (at ‘configChanges’ with value ‘keyboard|keyboardHidden|orientation|screenSize’ […]

Looks like this bug is back. The only way I can get around this is by setting the Android SDK target to 16in the application.xml file. I need to target 9, or 10 at the very least, and both seem to throw that error. Ideas?

Why not set min-sdk-version to 9, and leave target-sdk-version at 16?

That works great when the target-sdk-version is actually set to 16. If I make the min 9 and the target 9, it throws the same error; it can’t target its own minimum.

Why are you so intent on having target-sdk-version be 9? It sounds like it works fine the other way.

Client needs Gingerbread (API 9) support.

As long as minimum-sdk-version is 9 or less, it should work on Gingerbread.