Visual Studio version should I install


#1

Been getting the long delay (20 something minutes compile) and I read it may be connected to the version of VS I have. Currently it is 2010. Which one should I update to, 2013, 2015, 2017 ?
And I also read I have to check some libs in during install… do I have to remove 2010 ?
Any warnings and/or suggestions would be appreciated.


#2

I was installing OpenFL on Windows few months ago and at that time hxcpp had major problems with 2017 (i. e. compilation did not work and I couldn’t bother finding how to fix it, apparently M$ changed a lot of things in 2017 just cause and lot of things using VS compilers stopped to work, it’s only “path format” changes and such, but still).

tl;dr I had to uninstall every last trace of VS and install clean 2015, otherwise it didn’t work out of the box.


#3

Thanks for the tip, do you happen to remember the exact installation of 2015 you used ?
Trying to not mess current dev env.


#4
Microsoft Visual Studio Community 2015 Version 14.0.25431.01 Update 3

with

Visual C++ 2015

and other things (I basically installed everything installer had in the list and which I thought could be needed for something). I also have .Net 4.6, don’t know if it is necessary.

But if you don’t want to risk it, try to install it into some VM first to see, if it is working for you. I don’t use Windows build very often for development so something could have changed in a meantime.


#5

I believe I have used Visual Studio Community 2013 and 2015 successfully, just make sure you install the “for Desktop” version that includes Win32 support.

Visual Studio Community 2017 works on my system with this patch: