Problem building for windows


#1

Hi, I just installed HaxeDevelop and started using it with the current versions of haxe/lime/openfl. I created a simple OpenFL project for testing and hwen I try to build it for the Windows target, I get this error:

Error: 64bit is not automatically supported for this version of VC. Set HXCPP_MSVC_CUSTOM and manually configure the executable, library and include paths

It works fine for Flash or Neko. What can I do to solve it?

Another question: this seems a 32/64bit target issue, right? I want to have my executable running on 32bit systems (even if Iā€™m using a 64bit machine to build it). What can I do to adjust it?


#2

What version of Visual Studio?

Try openfl test windows -32


#3

the results

C:\Users\choki\Documents\Code\Haxe\AutoUpdate>openfl test windows -32
C:\Users\choki\Documents\Code\Haxe\AutoUpdate\bin\windows\obj>setlocal enabledelayedexpansion
Warning: Could not find environment variables for Visual Studio
Missing HXCPP_VARS
Error: Could not automatically setup MSVC

without ā€œ-32ā€

C:\Users\choki\Documents\Code\Haxe\AutoUpdate>openfl test windows
C:\Users\choki\Documents\Code\Haxe\AutoUpdate\bin\windows\obj>setlocal enabledelayedexpansion
Error: 64bit is not automatically supported for this version of VC. Set HXCPP_MSVC_CUSTOM and manually configure the executable, library and include paths
Error: Error: 64bit is not automatically supported for this version of VC. Set HXCPP_MSVC_CUSTOM and manually configure the executable, library and include paths


#4

Did you install Visual Studio Community with Win32/C++ support enabled, and reboot afterward?


#5

oops, the restart!
everything is working fine now. thank you a lot!