Issue with WebGL not displaying content on some browsers


#1

(copied from another topic)


#2

@VishwasGagrani Does this occur with any OpenFL sample? Has it always been this way on your Mac with every version of OpenFL you’ve tried, or did this change at some point? Thank you


#3

This one works fine on my browser ( mac/ff-53)
http://www.joshuagranick.com/examples/piratepig/html5/

If the above link is not of the latest version, I will upload and test the latest version of OpenFL Pirate Pig later. Will let you know then.

By the way my graphics driver is : NVIDIA GeForce 9400 256 MB


#4

Ok, I think I got the reason.
I turned ON the ‘Use hardware acceleration when available’ in

Firefox preferences->Advanced->Use Hardware acceleration when available.

Then closed and restarted the browser. And it’s showing the page now.


#5

http://www.renderhjs.net works on your Mac, after enabling “Use hardware acceleration when available”?

Does the “HelloTriangle” or “Stage3DCamera” sample work? Perhaps our standard 2D renderer works, but there is an issue with Stage3D (when hardware acceleration is not enabled in the browser), or perhaps it really is falling back to our canvas renderer


#6

I wonder if there’s anything we can do at this point:

If the WebGL context we get is not really hardware accelerated, and not really good, if that’s what’s going on. Using 2D canvas might be faster/more efficient in these cases


#7

It may also be worth testing -Dwebgl1 to disable use of WebGL2 (which is supported on Firefox, but might be related to what is going on here), or to set options.failIfMajorPerformanceCaveat = true before requesting the WebGL context


#8

Yes, it works and shows the content when enabling ‘Use hardware acceleration’.

Same with Hello Triangle too. When enabled ‘Use Hardware Acceleration’ it works, but when disabled it shows a white screen. Seems like it loads fine, but is not able to render it, but shows a white screen instead.