How to make my game run faster than 60fps on windows?


#1

I have turned off vsync and set fps higher than 60 in project.xml, but nothing happened


#2

Have you tried doing this on a simple project or sample (like DisplayingABitmap) so we know it’s not limited on performance?

What kind of GPU are you using?


#3

I created an AddingAnimation sample project and set <window vsync="false" fps="100"/>, but it still runs 60fps.
My graphics card is NVIDIA GTX 680.


#4

Maybe its a power setting?

http://nvidia.custhelp.com/app/answers/detail/a_id/3130/~/setting-power-management-mode-from-adaptive-to-maximum-performance

What are you using for the FPS counter? Does BunnyMark run faster?


#5

The fps counter is Fraps, and I think it shows the correct fps because BunnyMark cannot run faster too.

BunnyMark with <window width="800" height="600" fps="100" vsync="false"/>, and I have changed the graphics card power management mode.


#6

Thanks for your help! I did some tests, and it turns out that our native backend is defaulting to enabling vsync, so our code wasn’t properly disabling it.

This fixed it on my machine, if you use development builds, lime rebuild <target> should rebuild the native library with this change, otherwise hang-tight for the next release, and know everything’s probably fine on your machine :grinning:


#7

Thank you very much!