Haxeflixel Problem with testing on windows


#1

Hey guys, i need help with haxeflixel windows debug. I already downloaded vscode c++ compiler and i have already ran lime setup windows in my cmd. But any time i try to test my game on windows i get this errors:
cl.exe is not recognized as an internal or external command, operable program or batch file.
Error: Could not create PHC.
Please help, how can i get i to work.


#2

What version of Visual Studio or Visual Studio Community are you using?

If you have version 2017, I believe you need a development version of HXCPP

haxelib git hxcpp https://github.com/haxefoundation/hxcpp

Otherwise, I think you can use an older version alright. Make sure you check the box for “Windows C++ support” or “Win32” or “Windows Desktop” or a similar option for C++ when setting up Visual Studio, so that it installs the cl.exe MSVC C++ compiler


#3

I downloaded visual studio c++ compiler 2010. And i followed the link provided and downloaded it, i didn’t use vscode comunity


#4

Have you tried rebooting, or closing/opening the command prompt, to refresh your environment variables?


#5

Yes i Did. But it still gives me that error


#6

Try opening a command-prompt, and running this command:

echo %VS100COMNTOOLS%

It should print a value if everything is installed properly


#7

yes it printed out the location of my vscode c++ compiler 2010


#8

Could you try this?

1.) Run haxelib path hxcpp

2.) Change to the HXCPP directory

3.) Run cd toolchain && msvc-setup.bat

Does it properly print out all of your environment variables for Visual Studio 2010?

If this prints properly, and things are still not working, I would recommend installing Visual Studio Community 2015. It’s also possible that you have a newer version of Visual Studio (without C++ support) and HXCPP is finding that one, and not picking VS2010.

If you set %HXCPP_MSVC% manually, it’s possible to force HXCPP to use a specific installed version, such as set HXCPP_MSVC=%VS100COMNTOOLS%


#9

i tried to download visual studio 2015 but it keep telling me we do not have the download for you. Is this temporary do i have to wait a little bit more.


#10

What version of Haxe do you have? Could you share the output of haxelib list?

This is strange, normally cl.exe is not recognized as an internal or external command means Visual Studio is not properly installed


#11

When i first started install visual studio c++ compiler 2010, it gave me an optional download but i didn’t download it. Could that be the problem


#12

I just installed visual studio 2015. Should i choose the default or custom install.


#13

Try custom and make sure Windows (Win32) C++ for Desktop is checked, whatever the option is called :slight_smile: